SOLVED: Access truenas scale personal domain

Hello guys,

I followed this tutorial :
When i try to connect via my personal domain name to truenas i got this message “Connecting to TrueNAS … Make sure the TrueNAS system is powered on and connected to the network.”

Do you have some ideas ? What do i miss ?

Thanks a lot

If the UI loads but you get that specific message, it usually means Websockets are being blocked and the UI can’t talk to the API properly. It should be running over http/https depending on how you access the TrueNAS, so unclear on what is blocking you in this instance. (Caveat: I haven’t watched the tutorial to see how they set it up)

For future reference, it would be easier if you provided your configuration here instead of assuming we watch that video.

Show your nginx settings, did you enable web sockets when you created the proxy? He doesn’t in the video and taking @kris response into account that may be it.

There are many different ways to do this via the GUI and by more CLI approaches.

In CORE, you are limited to Route53 as a provider for SSLs, in SCALE the super-convenient Cloudflare provider was added also.

A known-working, provider-agnostic approach is via @dan’s excellent work re: SSL certificates, both from external providers as well as from a local CA.

If you’re talking about exposing the TrueNAS GUI to the Internet, it’s a bad idea. Don’t do it. If you have a need to access the GUI remotely, use a VPN.

That’s an orthogonal question to how to get certificates, and Nginx Proxy Manager will do that for you. If you want a cert for TrueNAS itself, there are options:

  • Get the cert through TrueNAS directly. As @Constantin says, this means you’ll need to be using Route53 for DNS if you’re using CORE, and either that or Cloudflare if you’re using SCALE.
  • Get the cert using a separate ACME client like, and use its built-in deployment script to deploy it to your NAS
  • Get the cert using, e.g.,, and use my script to deploy it to your NAS
  • Get a cert from a local certificate authority and deploy to your NAS
  • Ditch NPM and use Traefik/Ingress/Cert Manager

Works perfectly with websocket support activated…
Thanks a lot guys !

1 Like


If I understand correctly, making use of the new forums software it could be helpful to mark a post as solved, linking its solution.

1 Like