Weird permissions behaviour. NEED HELP!

Hello!

I am pulling my hair out because i cannot understand if I did something wrong, there is some permission weirdness or a bug.

On an SMB share on TRUENAS I have the following:

  • root is owner of filesystem ALC
  • brandid-office is group-owner
  • users A, B and C are all part of brandid-office group

If user A copies/creates a file somewhere on the share, the file logically will have A as owner, brandid-office as group BUT users B and C get permission denied when trying to access the files, both from the SMB share and from terminal via SSH.

The screenshot below shows one on the main folders inside the share where user A places files. But as I said B and C, both members of brandid-office group cannot acces the folders.

FYI, this looks like TrueNAS core and not TrueNAS scale (wrong forum section)?. What is output of getfacl for BrandID and one of the subdirectories?

It is TrueNAS Scale.
Some changes in the meatime that is why I ran getfacl 3 times.
I updated and reaplied recursively the same permsision on the TrueNAS GUI, filesystem ACL page. This gave me access as user B to all the files.
Then I copied a new folder “TEMP” with user A in this share and again, on the newly copied file, user B has no access.

So first time I ran getfacl on BrandID, then on a subfolder and then on the newly copied folder and the permissions look very wierd. I do not understand what that means and how can it be fixed.

Not quite sure what the issue is here but personally when using SMB I prefer to leave the owner and group section alone so default is root/wheel and instead add an ACL entry in this case for your brandid-office. You can remove all the other default entries unless you want/need them. I can confirm this has served me well for many years on CORE and seems to work fine on SCALE.

1 Like