Making Jails network DHCP in Truenas Scale with jailmaker

No problem! Enjoy jailmaker :smile:

1 Like

Good old PEBKAC :slight_smile:

1 Like


I have followed the jailmaker git hub directions to a T.

I have watched innumerable videos, scoured the net, no matter what, i am not getting connectivity to the host from the container.

I have tried --network-macvlan=ifacename

along with the others from the docker config template.

i have also tried not using a template.
i have tried just making a debian container,
I have tried using docker_compatible
i have tried using capability all
disabling seccomp

no matter what, I am not getting network connectivity.
DHCP or Static, following the guides to a T.

i feel like maybe there is a new version of something that is causing me this much pain ?

(also my containers ONLY EVER HAVE LO, AND HOST0, nothing else)

Did you add an interface to your bridge in the TrueNAS ui?

Ha! That was amusing…I caught that difference as I was scrolling through your terminal output and thought “I bet that’s the issue” :slight_smile:

I’m now fully happy with my Dockge stacks. I spent a bit of time trying to get the sockets php extension to install in my php-fpm nginx stack using a dockerfile without success. Eventually worked around by using an image with the extension preloaded (chialab/php:8.3-fpm, in case anyone’s interested).