Problems Updating Solved!

Hello Forum!

For years my truenas system updates worked perfect.

But now I am running continously inte the same error regarding a downloaded update file:
has a checksum error.

I rebooted the system but it did not help.

I was looking where I could manually download the file but could not find it.

You may laugh at me. But I’am not able to determine what system I have!!!

Freenas, Truenas Core etc.

I installed the system a few years ago never had any problem so I forgot.

Please help an idiot like me!

Thank you!!!

Can you log into the web interface on your system? If so, it should tell you on the first page you see there.

Thank you dan!

Shameful I have to say Iam using TrueNas Core!
Version TrueNAS-13.0-U5.3

Hi Davvo!
Does that mean I should download the whole iso and tell the system to update from that file?
If yes. Where do I have to place the iso file?

You asked where to manually download the file, those are the links for the .tar and the sha256 to verify the downloaded file’s integrity.
In order to update with that, after you downloaded the .tar to your main computer and (optional) verified with the checksum it’s intact you have to go inside System>Update in the WebUI (or click on “Check for Updates” in the page after logging in the WebUI as dan was telling you).


Thanks to @winnielinnie for reminding me I’m a dumb owl.

…and this is really the way you’d ordinarily do an update. You shouldn’t need to manually download a file from anywhere to upgrade your NAS.

1 Like

ISOs are not for manual updates. They are for full (fresh) installations.

The manual updates are .tar files.

Here is the manual update file for 13.0-U6.1.

Here is its sha256 checksum.

1 Like

I’m an idiot.

1 Like

This is a bit concerning. It implies that when fetched (via the GUI), the update file is corrupt after downloading to your server? :neutral_face:

1 Like

Yes. I tried to download via the gui a few times without success.
This never happened before.
In another thread here someone had a similar problem regarding Version 12 and he fixed downloading a .tar file and running manual update.
What is the url where you can download those manual update tar files?

If only someone would have posted such links earlier in this thread.

If only…

I do believe I got similar problem on scale when my one of the boot-pool SSDs were dying.


Yes winnielinnie I know you already did!
And of course this solved my problem!!
One more big thank you to you!!
Your link pointed directly to that file!
But in case i am running again in such a problem where do I have to look for these tar files?

FreeNAS / TrueNAS Direct Downloads

You browse it in similar fashion to an FTP directory.

It holds not only the manual update files, but also the ISOs meant for fresh installations. (No need to use this alternative download page, since the latest stable versions can be found on the TrueNAS home page, anyways.)