TrueNAS can't ping VM but VM can ping TrueNAS


I have a strange problem with a SCALE system (23.10.2):
I installed a Win11 VM on it and it works ok, i have followed the official docs and created a bridge.
The VM has internet access and can ping the TrueNAS host just fine.
However from TrueNAS I can’t ping the VM and i cannot understand why.

I also have another TrueNAS system on the same version with an Ubuntu VM and by doing the same process of setting up a bridge etc. I can ping the VM from TrueNAS just fine.

Any help would be greatly appreciated, thanks.

Without further information that’s hard to tell. I don’t have a Windows VM so I can’t quickly verify if it’s related to that specific VM.
Can you show your network setup?

TrueNAS network setup is as follows:

enp0s31f6 is a member of br0

The VM has a static IP ( configured on the NIC in windows (VirtIO NIC, but i even tried the Intel one and i have the same issue).

If you configured the NIC in windows and didn’t use default settings, maybe also show that.

Just to confirm, when you ping .98 you get a timeout / unreachable?

What does


yield in windows?

I’d suspect the windows VM is reachable under a different IP than you expect.

Do an


from one of your Linux machines on the Network.

I have a limit of only one image per post so here is a quick MS paint job of the three screenshots:

When i ping the VM from TrueNAS i don’t get any response, the command just hangs until i press CTRL+C and then it shows me the statistics, 100% packet loss

On this network i don’t have any other Linux machines unfortunately.
I have tried the

ip neigh | grep br0

command on TrueNAS and it returns the correct MAC addr of the VM it seems.

Ok so it seems it was Windows firewall blocking pings apparently, i have never seen windows firewall blocking pings but whatever, after i completly disabled the fw it works fine and i can ping the VM from TrueNAS.

I face another issue however, i have Tailscale installed as an app on TrueNAS and it works, to a degree.
In fact i can remotely access all the devices on the same LAN as the NAS but the VM and my end goal is exactly RDPing into the VM remotely via Tailscale.

After seeing your settings that would have been my next guess, but I’ve never had a Windows machine not respond to ping in its default settings.

For your second question, I don’t use the app, check this link,.maybe it’s related

Tried rolling back to Tailscale v. 1.54 but the issue persists.
With both 1.54 and 1.62.1 i can remotely ping and access other devices on the LAN, the only thing i can’t ping is the VM.

Just to double check, I’m not a Tailscale veteran, I’m looking into it myself currently.

What routes are you advertising in Tailscale?
Can the VM reach the other Tailscale nodes?

Can you deploy Tailscale in a docker container to see if it’s just the app or if there is another problem why it doesn’t work?