5 brand new seagate disks but unable to create pool. Error 6

I am running TrueNAS-13.0-U6.1
This will be the 5th pool I am trying to create.
I added 5x *TB seagate drives.
I wanted to add a new pool with the disks called RaidzDisk4.
first attempt I get the following error: [EFAULT] Failed to wipe disk ada1: [Errno 6] Device not configured
I tried to wipe the drive manualy, no problems. I wiped all 5 drives manualy just to be safe. All no problems wiping.
I try to create the pool again but get the same error but this time on ada2.

At this point I suspect the drives are fine but something else is going wrong. I dont know where to look next. ChatGPT is not helping much.
Can someone help me?

‘ada’ suggests that the drives are not attached to a RAID controller, but the mandatory preliminary question remains: What is the hardware? (Is there a “many-SATA-ports-on-a-M.2-stick involved”?)

Take the drives out of the TN machine. Put them in a windows box and use diskpart to clean each disk.

Then try again. The TrueNAS wipe option seems less than reliable

If it is a mere matter of wiping the drives, this can be done in the NAS.
The magic incantation is something along the lines of (can nuke more or less of the partition map…):
dd if=/dev/zero bs=1M count=100 of=/dev/ada2
Triple check the target (of=…) before hitting Enter! :see_no_evil:

My configureation
Supermicro X10SRL-F
Intel(r) Xeon(R) CPU E5-2630L v3 @ 1.80GHz
47.8GB mem
3x HBA expantion cards providing 8 extra sata connections each.
Boot drive is a mirrored ssd via external usb case.

All 5 drives are directly connected to the mobo not the HBA’s.
I also now notice that 4 out of 5 drives fail short S.M.A.R.T. tests. But no error is provided.

Solid hardware foundation (but three HBAs?), but failing even short SMART test is bad omen.
Check the output of smartctl -a /dev/adaN for all applicable values of N.
“RMA or bin” is the likely outcome.

As usual, the answers are very much not to be found through ChatGPT…

For a total of 34 ports, including the SATA ports? Sounds like a cabling nightmare.

Unless they failed due to a host reset (i.e. the power went out on them) they are 100% defective and need to be returned as such yesterday. Failing a long test would be bad enough, failing a short test is an achievement.

1 Like

How many drives installed total? Subject 5 just added to a fully functional system?
Power supply info?

1 Like