Access NFS share via linux

Hello I have recently tried my hand a true nas, have it all setup with pools and data sets but I am having an issue accessing the share in NFS with linux, I have created a user in truenas with the same login and credentials as my linux box but after mounting the drive it says that user ID 3000 has control when I have triple checked on the true nas box and my user is listed as owner. What am I doing wrong?

You might have to map them to 1000, which is the default used by the popular Linux distros.

SCALE, for some reason, defaults to 3000 for the first user you create.

Yep that worked, thanks so much.

We default to 3000 to avoid collisions with many apps. Collisions here could cause unintended escalation of filesystem access.

1 Like

NFS protocol knows nothing about usernames (unless you’re using kerberos). It’s UID/GID only. This means without having some common ID source for client and server or using mapall parameters acces will be at best undefined. If you have this working with other distros via NFS and it’s working as expected, then it’s working mostly by accident because you just happened to create same username with same uid.

1 Like

In a home / small business environment, this is probably manageable, but in any larger environment I would imagine you need some means for managing userids/UIDs/groups/GIDs across your user base and then link TrueNAS to that.

If anyone wants to give an overview of how to do this for those that follow in months to come, or provide a link here to existing information, that might be helpful.


That’s fairly trivial to do. Just deploy an LDAP server or Active Directory and join TrueNAS and the clients to it.