App edit pages inaccessible and restarts broken


I am running on Dragonfish-
I am running a mix of official truenas apps and custom apps.
I have 2 issues:

1/ when I stop an app and restart it its webui no longer works, it doesn’t matter what app. I have to delete it, restart (because the dataset is in use…), reinstall, and then the webui is back

2/ none of my app edit pages are available. this persists after a reboot and re-creating the app from scratch.

What did i break? this applies to all apps. I use a bridge network as my main network over my ethernet interface and have no config for the k3s service (node, rest all empty/default)

how can I diagnose this or fix the middleware that seems to be broken?


restarting an app through heavyscript doesn’t seem to brick it :thinking:

Seems to be a specific UI problem.

Which browser are you using? Have you tried clearing cache?
Do you see any errors in the browser console (developer tools)?

EDIT: not fixed

If you can reproduce the problem without any TrueCharts installed and with an Official app you should create a bug report.

So the “Edit webui” problem is still here, but does not apply to all apps. I tried on a different pc with a different browser (new install of firefox) and issue persists.

Error in web console is:

I suggest you to create a ticket here with all these details, including the official Apps having issues and that screenshot so we can get to the bottom of this.

Ended up nuking the ppol and recreating, problem “solved”
I saw a lot of leftover truechart namespaces even though I had deleted them.

I guess the leftover stuff broke things