ASRock E3C236D2I Hangs on System Initialization after moving to a new case

Hi all,

I switched case (Node 304->804) last week and have issues starting the system.
In Java remote I see that it hangs on “System initialization…55”. Searching in forums and online I saw users reporting this as a sign of faulty MB. My system ran fine (6 HDD) in 304 for about 5 years thus i would not expect it to fail exactly at the time when I swap cases, who knows.

The only difference between old and new setup is that I do not attach case fans to MB, but use controller on the back of the case provided sata power.
Also new case comes with 8pin (2-rows) HD-audio which I don’t think I can plug into 4pin speaker on MB.
That’s all I can think of that is different between the two setups.

Upon starting the MB behaves ok: green LED near ATX power and blinking green LED near BMC (heart bit).

If anyone had similar troubles with ASRock MB, I would appreciate any hints/advices how to move forwards and troubleshoot the issues.

On my todo:

  • unplug hdd power
  • reseat RAM
  • reseat power cables
  • reset CMOS
  • if nothing helps try RMA (although MB was bought end 2017)


I would check that you don’t have something like an unused standoff on the new case touching the back of the motherboard if the cable and ram reseating doesn’t fix it.

1 Like

You might have scraped off some mosfets in the moving: if anything does not work, make a full board check.

Thank you both for the advices.

Interestingly enough, TrueNAS starts without HDD’s plugged in… will now try to plug them one at a time to see which one is causing it… Maybe BIOS tries to boot from HDD as soon as they are attached…

1 Like

Might also be a PSU issue.

As soon as plug in a single HDD, booting hangs…
Tried swapping PSU (Seasonic->Corsair): boots without HDDs and hangs with 2 attached.

Careful, did you change the wiring / harnesses also? The pinouts can vary by PSU OEM, even if the plugs fit.


I have not changed the sata cables of PSU, cables between Corsair and Seasonic are indeed easy to mix. For me cables from Corsair RM 650X have “Type4” written on them

1 Like

Be super careful. If you have a PSU with just receptacles on it (i.e. “modular PSU”) I’m pretty certain that the wiring harnesses between Corsair and Seasonic are NOT the same, will cause issues. If you have to change the PSU, you also have to change the cables. Even within an OEM I would be leery to keep the same cables between different PSU models…

I keep the PSUs I own in their boxes with their respective cables for that reason. I suggest you change the cables to be OEM-aligned and please report back. It’s the most likely reason the PSU goes on strike when the HDD is attached, i.e. you are likely shorting a 12VDC or 5VDC rail to ground.


Thank you for the advice, makes sense.

I was not precise, when trying different PSU I did swap all power cables. I meant to say I did not mix them.

1 Like

Are you able to change the CMOS battery?

I have unplugged all HDDs from MB while keeping them attached to PSU and the system boots. Will try changing CMOS battery next…

It really feels like a boot order issue though, please double check any BIOS settings.

will do, it’s a bit tricky without a VGA monitor around :wink: will order VGA-to-HDMI adapter to try to get into BIOS as Java remote is not working reliably… ;-(

1 Like

I tried one VGA-to-HDMI adapter (BENFEI), but it did not work ;-( Bought another one (coming tomorrow)…

Anyone has experience with those and can recommend a specific brand that worked?

I think I finally got this working:

  1. Know your IPMI LAN port. I completely forgot that there is a dedicated LAN port for this. Once I use it I could reliably connect using Java through Docker (solarkennedy/ipmi-kvm-docker) on my Mac.

  2. Check boot order. This was indeed the issue as suggested by @Davvo . Once I selected “UEFI: SanDisk, Partition 1” TrueNAS booted, but shares and web interface did not work…

  3. Know which drive to boot. As MB supports only 6 SATA, I have 2 USB sticks for OS. I did not take a note which one was plugged into what USB port when changing cases. I setup the build more than 5 years ago and details fade. I guess one has to boot from the same stick as used last time. Once I swapped USB sticks without touching boot order in BIOS, TrueNAS booted again (presumably from another stick) and web interface as well as shares worked.

Lesson learned.

Thank you all for troubleshooting this. This was a very stressful week. I do have a backup on a single 12 TB HDD (rsync’ed), but I would rather not get into situation where I need to rely on it.