Assigning subnet under System Settings --> Advanced --> Allowed IP Addresses

A quick one, think this should be setting what IP addresses allow to connect to the server, though:

  1. Can I set a subnet like XXX.XXX.XXX.*?
  2. That’s for GUI admin tool only or everything?
  3. How to reset if messed up… read some articles that to run CLI command but not too sure…

Thanks all the experts :man_bowing:

For Scale, System Settings/Advanced/Allowed IP Addresses

  1. Subnets are set with a netmask, not an * so your example would be
  2. “IP addresses and networks that are allowed to use API and UI. If this list is empty, then all IP addresses are allowed to use API and UI.”
  3. Don’t mess up. :smiley:

Oh… actually … I messed up … .wrong IP address added and now “Access restricted” from UI … any idea to reset from logon server locally?

Oh… found a page and here how to fix/reset the list to blank again:

  1. Access your server locally, plug in keyboard and monitor.
  2. Select option 6 “Open TrueNAS CLI Shell”
  3. Type “system general update ui_allowlist=” (that’s “[” and “]”… somehow changed to symbol when saved in this reply … )
  4. Type “system general ui_restart”
  5. Type “Exit” after finished. Wait for a few sec the local server display should showing the original option list.

A bit scary though thinking need to re-install again :cry:

hmm… still not getting what I needed… I want to setup and only allow any machine within the same subnet to access but it’s wired that I can only add 1 hard IP address… or I missed anything?

If you want a single subnet, the format is ip-address-of-net/maskbits, so for a typical home-router subnet with 255 addresses, an example would be 24 mask bits is equivalent to a subnet mask of if that’s more familiar? Your original question with* would be correctly specified as

If you’re not sure how to specify, I’d recommend looking at an online tool like Online IP CIDR / VSLM Supernet Calculator

1 Like

Hi gnewt

Thanks for your reply, though I tried the same format and returned “Enter a valid IPv4 address.” and cannot be saved… Somehow I couldn’t find any documents for this functions and no clue how to setup correctly …

Are you sure you’re entering the subnet correctly? I’ve just tested on my end with no issues.

1 Like

No luck… whenever I add “/” it prompts “Enter a valid IPv4 address.” and the save button will be dimmed. And my last try that can save is without the “/xx”. But then it seems not recognized as a subnet but as an individual IP address and no PC can connect to it.

What version are you on? The SCALE UI didn’t support adding a subnet to that field before Dragonfish.


Hi DjP-iX and all

Thank you so much for your help. Indeed that’s the problem which my NAS still below Dragonfish… after upgraded all works fine now :laughing: