At startup always "Failed to configure kubernetes cluster for Applications"

Since 23.10.2 I had always the problem, that on reboot of my machine I did get

Failed to configure kubernetes cluster for Applications: Unable to lookup configured interfaces: enp2s0

Only solution so far was, that I hat to manually unset the pool and then set the pool again. That always solved the problem … till next reboot.

I was desperately hoping that upgrade 23.10.2 β†’ 24.04.0 may solve this but again it is there.

Any advice to solve this sustainable is highly appreciated.

Thanks in advanced

Sounds like that device isn’t coming up quick enough before k3s gets started. We have a similar issue in the queue for 24.04.1 that I suspect would fix this as well:

1 Like

Thank you for pointing out this ticket.

I remembered that there had already been a few posts on this topic in the past. However, I was no longer able to locate them - and then there was the forum change too.
There were various threads on the old forum with possible solutions, but unfortunately none of them worked.

So all that remained was to hope for the next update. So here too …

I’m eagerly awaiting 24.04.1 and keeping my fingers crossed.

Just installed Dragonfish-

Issue is gone now. I am so happy …