Boot issue - grub_is_lockdown not found

Hello everyone, I am relatively new here and has only been using Truenas core for 3 years and scale for ~3 month, currently running Cobia on a custom build system (repurposed an old system). I am not an IT professional and only has this home lab as a hobby so I may need some extra help here. Thanks in advance!

I have been slowly swapping each of my drives from 12TB drives to 18TB drives with the plan to expand storage once my 8 drives running on Raidz2 are all swapped. I am 3/8 complete and is just finished swapping the drive #4 physically when I ran into this.

I did physically touch one of my boot drives (one SATA ssd) while swapping the data drive so it is possible that something is physically wrong. But I have the boot pool running in mirror (with an NVME drive)

Basically after I close my tower, I ran into a boot issue that goes to show grub menu after the boot process goes to check HDDs on both SATA and HBA ports. The Grub menu says “error: symbol ‘grub_is_lockdown’ not found. Entering rescue mode”.

I am not sure how to resolve this and have found some similar issues via google such as Reddit - Dive into anything

However, none of the issue is exactly matching mine as they seem to be related to either installing, upgrading from core to scale, or swapping boot drive.

The solution of reinstalling isn’t ideal for me to try first without asking because:

  1. I did upgrade from core to scale, about 3 months ago, but that process went fine without issues.
  2. I have been swapping data drives (3/8 complete) and my workflow this time is not different from the first 3 times ( Disk Replacement | TrueNAS Documentation Hub ), with the exception of physically touching one of the boot drive.
  3. I do have saved config from webUI in the past, but I do not have any since I started swapping drives, and I am not sure if those config files are still usable and don’t want to jump to re-installing without knowing I won’t make it worse. I believe I can always start config from fresh as long as I can import the pool, but I would hope not having to do that if possible.
  4. I tried to entirely disconnect the boot drive I touched and the same issue still occurs with only the NVME boot drive in place
  5. I have not tried to swap back the data drive I touched, but I doubt that it is the source (please correct me if my assumption is wrong)

Is there any way for me to resolve this error? Any guidance and help is appreciated!