Boot Loop issue Dragonfish

Hi Guys,

As a newbie I would like to ask for some help regarding a boot loop situation that I have since yesterday.

I was realizing that my truecharts apps was not synced so I did a restart of the server. Restart went well but still no syncing, so I did a second restart, and this time it gets stocked in a loop at the beginning and is never getting out of that.

This is how it looks, and it don’t get any further, just start the same over and over again.

Boot/system is on Nvme.
1 software pool with 2 ssd’s in mirror (all apps installed here).
1 tank pool with all media.

in Bios and also at startup (attached picture), all discs are showing up, so I have no idea what the cause of my issue could be, and also not on how to continue.

I hope someone is able to help or guide me how to solve this issue.


This all looks like a BIOS screen, nothing to do directly with TrueNAS.

  1. Check your BIOS settings to ensure the NVMe is the boot drive.
  2. Force the Bootstrap from the NVMe, typically you can press a key to get to a Boot Menu while the computer is running the BIOS checks.
  3. If none of that works try the following:
    a) With the power off, Remove all your drives (disconnect the data cables at a minimum) except the boot drive (NVMe). Power on the system. Does it boot to TrueNAS?
    b) Do you have a backup of your TrueNAS configuration? Hope so. Here is where I tell you to rebuild the boot drive. Leave the other drives disconnected. Does that work?
    c) IF you are able to get TrueNAS up and running, power down, reconnect your drives, power on, hopefully you get to TrueNAS again. Now restore your configuration file.
    d) IF nothing is still working, perform a factory reset on your BIOS. Try to bootstrap again.
    e) IF you cannot get TrueNAS to run at all on your NVMe drive, maybe there is some issue with the NVMe drive. Try a SSD/HDD if you have one laying around (you can use a USB Flash Drive as well), even if you do not have enough connections to restore your system to full operation. We are troubleshooting and trying to isolate the problem. IF the system works with a different drive then the NVMe is somehow to blame, be it the NVME or motherboard. A USB drive is a good temporary fix by the way.

If you are unable to get this to work. Report back with detailed information on exactly what you tried and exactly the results you observed. I’m hoping that steps 1 or 2 fix the issue.

Good luck.

Hi joeschmuck,

thanks for your reply.
Yes youre right…it looks like bios, but that is the screen I get when power on my server, it never gets any further.
I will try your suggestions out.
my own thinking is that it could be the boot drive, even its only 2 years old.

I checked the bios already and boot priority is the correct one.
I have a backup config from so I guess that could be used.

furthermore I have 3 unassigned discs in my system, so do you think that I should try to make a new install on one of these…???

whats just so strange is that everything was running so smooth, until my second restart


It was my NVMe system drive causing the issue.
I disconnected all other drives and truenas still not boot up.
I made a fresh install on a new ssd and all is back to normal.