Can not connect TimeMachine share - The selected network backup disk does not support the required capabilities

I setup a TimeMachine SMB share but when I wan to set it up on my mac and connect to it I always get this error:

The selected network backup disk does not support the required capabilities.

Apparently this is a very common issue and the solution is somewhat related to setting the Quota which I did but it does not seem to help.

These are my settings:

The user which I want to use to connect to the TM backup from my mac:

The dataset settings:

The permission on my Dataset:

I also added a user quota on the dataset since one post suggested this:

I tried every possible combination with Quotas/Permisson but nothing seems to work…

I am running TrueNAS-13.0-U6.1

What is output of testparm -s?

I solved it. In the SMB sharing settings there is a setting called “Use Apple-style character encoding” which is not enabled per default.

This fixed it

FYI, this parameter should have no impact on whether time machine works.

this is strange because it was literally the only thing I turned on before it started to work.

The configuration change may have restarted the mDNS service. Just FYI, I’m noting here that it’s not required in case someone else looks at this thread in the future to troubleshoot an issue.