Can ping router, but not other devices and vice versa, but can access library from Plex app

I have a strange issue. My setup was working perfectly yesterday, and suddenly today is acting strange.

I am using truenas for a Plex server and file server. I run sonarr, radarr, and sabnzb in one jail and Plex in a separate jail.

As of today, I can no longer access my files, nor my sonarr, radarr, sab jail. Nor can I access the truenas dashboard or Plex server.

But from the Plex app on another device, I can access my library and still watch shows/movies from my server.

I can ping .my router from all devices on my network, including from truenas shell console (attached monitor directly to server). But I cannot ping truenas (or any jails) from other devices, and cannot ping other devices from truenas shell.

I read a bit about realtek NICs having issues in truenas, which I do have a realtek, but it’s strange because everything worked fine yesterday.

I’m a noob who literally just followed a YouTube video to get this set up and it’s run perfectly for about 2 years until now. So I’m completely lost. On the off chance it is a NIC issue, I ordered an Intel NIC so I’ll update when that is delivered. But besides that, any ideas?

MB gigabyte B560M
CPU Intel i3 10th gen
HDDs 1 WD red 3TB and 1 Seagate 3TB mirrored.
NIC is onboard MB (just ordered Intel NIC to try)

Sounds like you were using DHCP and your router changed the address, can you check? Unlikely to be the NIC’s fault here, more like a configuration issue.

Hi, thanks for replying.

That’s a negative. Truenas and jails are set with static IPs. From the truenas console (IDK if that’s what it’s called but the screen when a monitor is connected directly to the server) it shows me the same IP address Ive always used.

Did you try rebooting?

First thing I tried. Multiple times.

It would make more sense if I could not access my Plex library from the app on other devices. But I can. But I cannot access Plex via the IP address.

If you try connecting to the WebUI, what does happen?

Networking configuration issue imho. I am not very familiar in how to help you troubleshoot this beyond telling you to look into your own router.

Turns out att pushed an update to my router that broke my local network. Now they pushed another update to fix that and broke Internet service, but I can now access my server locally. Get your crap together, att

1 Like