Cannot access TrueNAS through the web interface

I cannot access TrueNAS through the web interface.

After I enter the IP of the TrueNAS I get black screen with a notice:
“Connecting to TrueNAS … Make sure the TrueNAS system is powered on and connected to the network.”

I have tried on different browsers. And also as a Guest in Google Chrome. And in incognito mode in Google chrome. And also in Firefox. I also cleared the cache of the browsers. I get black screen with a notice.

The server is powered on.

I can ping the server.

I have also tried to forcefully shutdown (unplug) the server and turn it back on. In the meantime the Ping failed and resumed when the server booted.

What else can I do?

I don’t have SSH enabled, so I can’t login that way.

I believe the version is TrueNAS 12.8?


Is your browser defaulting to connecting with a HTTPS session (port 443) but the NAS is only set to reply on HTTP (port 80)? Did you ever enable SSL via @Dan’s script or the GUI on your NAS?

I’d say you really should have it enabled, but it’s water under the bridge at this point.

What’s showing on the server console? At this point I’m guessing we’re dealing with a failed/failing boot device, but it’s really hard to say without knowing more.

Yup, if it’s not a HTTP/HTTPS issue then the next logical step is to monitor the boot process and perhaps log in and make necessary changes via the console. I hope @Bostjan can do that!

This strikes me as somewhat unlikely, given that something is showing up. If that were the issue, I’d expect a connection error. But definitely not sure here.

Attach a monitor and keyboard to it or use IPMI if available to see what the console shows.

I attached a monitor and keyboard to it. I was able to log in (console?).

Then I ran these two commands (below) and it helped. After that I could login through the Web UI.

service middlewared restart
service nginx restart
1 Like

Would probably be worth raising a bug for this as middlewared/nginx failing unexpectedly until a service restart is odd (especially seeing as it had seemed to persist through reboot).

1 Like