Cannot Connect to vTrueNAS From Outside Host Machine

Good Morning,

I am running TrueNAS Core in a ProxMox VM.
I have created a pool and enabled SMB share.

I can access the share from a Windows VM hosted on the same server.
But I cannot access it from my local desktop.

This is what I see on my Windows VM:

However when trying to do the same from my local desktop, I can see TRUENAS on my network, but when I try access it, it says that the network address is invalid or the network name cannot be found.
I can ping the server just fine, as well as access my TrueNAS dashboard, so my connection to the VM appears fine


Pinging with 32 bytes of data:
Reply from bytes=32 time<1ms TTL=64
Reply from bytes=32 time<1ms TTL=64
Reply from bytes=32 time<1ms TTL=64
Reply from bytes=32 time<1ms TTL=64

Ping statistics for
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 0ms, Average = 0ms

In Proxmox I have dissabled the firewall as a test without success

Personal preference but I don’t use the windows network discovery. Did you try to map the share the same way you mapped in in your VM via its IP address?

Did you enable all the broadcast options in truenas (netbios, wsdiscovery etc.)?

I’m not trying to add it via network discovery.
But trying to add is using \TRUENAS\ or \\ is not working.

I did try map it the same way I did in the VM, but that failed.
I can also fully explore the NAS using network discovery on the VM.

Here is an image from my Network/Global Configuration, hope this is what you were asking me to confirm

Please upload the images to the forums directly.

\\<TN IP>\SMBSharename

This is what you tried to map? What is the name, not path, of the SMB share you are trying to map? Is it Share?


Should be \\\Share it’s a double slash.

Apologies, new to the forums.

Yes, I’ve tried to map to \\\Share

Another apologies, I put \\ but it removed the first one because I didn’t put it in the code section.

The result of trying to connect:

I did the exact same thing again now on the Windows VM and it instantly adds it to my list of drives:

Virtualization is not my wheelhouse, but for clarification: the subnet is the same as your local subnet?

With the firewall down I wouldn’t know why you shouldn’t be able to connect, but I assume the issue may be related to your proxmoxx setup then.

I’m not clued up on subnets, but all my device IP’s start with 192.168.10

And if I go to cmd and run ipconfig /all I get the following:

Ethernet adapter Ethernet:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Realtek Gaming GbE Family Controller
   Physical Address. . . . . . . . . : 
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : 
   IPv4 Address. . . . . . . . . . . :
   Subnet Mask . . . . . . . . . . . :
   Default Gateway . . . . . . . . . :
   DHCPv6 IAID . . . . . . . . . . . : 
   DHCPv6 Client DUID. . . . . . . . : 
   NetBIOS over Tcpip. . . . . . . . : Enabled

If it’s working in general for the VM then I don’t know how to proceed unfortunately. I didn’t see any obvious flaws (like using an internal IP within proxmoxx or the likes). And apparently the machine responded to ping from outside your network.

Did you set any allowed / deny hosts settings in your SMB share?

To my knowledge I don’t recall seeing that.
And don’t recall adding the Windows VM to anything specific.

For sake of completion, I will post images of my shares configuration.
Really lost as to what else could be wrong

Update: Something must be wrong on my local machine.
I just tried from my better halves machine (Don’t know why I didn’t try before) and it connected 100% fine first try.
Something on my computer must be blocking the SMB, even though I can ping the server.

I’ve disabled firewall with no success.
But I believe this now falls outside of a TrueNAS support query.

You could compare the SMB settings under Windows features and try to remove any saved credentials (credentials manager) for the SMB on your local machine. In my experience windows isn’t great with giving you a correct error message in that regard.

Try deleting the credentials and remapping first.

@chuck32 I’m happy to report I found the problem.
My VPN running on my computer was apparently configured incorrectly.

Name Servers were set to “Follow App Rules”, changed to “VPN DNS Only” and it’s working as intended…

This has been a 3 day battle back and forth.

Thank you for trying what you could, with your help I poked in places I likely wouldn’t have before.

CASE CLOSED :smiley:


Great you solved it. Feel free to mark your answer as the solution.

Have a nice weekend!