Cannot delete dataset is busy

Hello there,
i try to delete a dataset but can not because it seems to be busy, either from the gui nor the shell.

root@truenas[~]# zfs destroy  four10tz/Xen02/data01
cannot destroy 'four10tz/Xen02/data01': dataset is busy

i deleted the iscsi share before, but with no luck. also the -r -f -R options does not help. i already tried to stop the iscsi service and delete the dataset but with no luck either :confused:

root@truenas[~]# grep data01 /proc/*/mounts

gives no output

Have you tried to reboot the NAS? If it is still busy, if you have any VMs or similar, stop them.

1 Like

Sry for the late reply.
i had no opportunity to retstart, itยดs a busy storate host for a lot of hypervisors.
this truenas machine serves only as nfs and iscsi storage for xen hypervisors. the share was unmounted and deleted before.
is there any other option besides reboot i can try?

i was able to squeeze in a reboot, but unfortunately i still cant delete these datasets.
is there something i can check?

Any snapshots being โ€œheldโ€?

zfs list -t snap -o name -r | xargs zfs holds

nope no snapshots related to this zvol.

i tried deleting the zvols via the bootup command but with no success either :confused:

i also created a new zvol on the same pool, shared it via iscsci, conneted it to an xcp-ng host as storage, moved 1 disk of a runnig vm to it and back und then deleted the zvol with no Problem. whats the difference here ?