Cannot import "tank" as "tank": I/O error


today I cleaned my NAS PC, after booting the pool called tank disapeard. I tried to import the pool in the GUI, but just got the error message: “[EZFS_IO] Failed to import ‘tank’ pool: cannot import ‘tank’ as ‘tank’: I/O error”.
Under more Info is written:
` Error: concurrent.futures.process._RemoteTraceback:
Traceback (most recent call last):
File “/usr/lib/python3/dist-packages/middlewared/plugins/”, line 438, in import_pool
zfs.import_pool(found, pool_name, properties, missing_log=missing_log, any_host=any_host)
File “libzfs.pyx”, line 1265, in libzfs.ZFS.import_pool
File “libzfs.pyx”, line 1293, in libzfs.ZFS.__import_pool
libzfs.ZFSException: cannot import ‘tank’ as ‘tank’: I/O error

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
File “/usr/lib/python3.9/concurrent/futures/”, line 243, in _process_worker
r = call_item.fn(*call_item.args, **call_item.kwargs)
File “/usr/lib/python3/dist-packages/middlewared/”, line 115, in main_worker
res = MIDDLEWARE._run(*call_args)
File “/usr/lib/python3/dist-packages/middlewared/”, line 46, in _run
return self._call(name, serviceobj, methodobj, args, job=job)
File “/usr/lib/python3/dist-packages/middlewared/”, line 40, in _call
return methodobj(*params)
File “/usr/lib/python3/dist-packages/middlewared/”, line 40, in _call
return methodobj(*params)
File “/usr/lib/python3/dist-packages/middlewared/”, line 1383, in nf
return func(*args, **kwargs)
File “/usr/lib/python3/dist-packages/middlewared/plugins/”, line 444, in import_pool
File “libzfs.pyx”, line 465, in libzfs.ZFS.exit
File “/usr/lib/python3/dist-packages/middlewared/plugins/”, line 442, in import_pool
raise CallError(f’Failed to import {pool_name!r} pool: {e}', e.code)
middlewared.service_exception.CallError: [EZFS_IO] Failed to import ‘tank’ pool: cannot import ‘tank’ as ‘tank’: I/O error

The above exception was the direct cause of the following exception:

Traceback (most recent call last):
File “/usr/lib/python3/dist-packages/middlewared/”, line 427, in run
await self.future
File “/usr/lib/python3/dist-packages/middlewared/”, line 465, in __run_body
rv = await self.method(*([self] + args))
File “/usr/lib/python3/dist-packages/middlewared/”, line 1379, in nf
return await func(*args, **kwargs)
File “/usr/lib/python3/dist-packages/middlewared/”, line 1247, in nf
res = await f(*args, **kwargs)
File “/usr/lib/python3/dist-packages/middlewared/plugins/”, line 1459, in import_pool
await‘zfs.pool.import_pool’, guid, opts, any_host, use_cachefile, new_name)
File “/usr/lib/python3/dist-packages/middlewared/”, line 1368, in call
return await self._call(
File “/usr/lib/python3/dist-packages/middlewared/”, line 1325, in _call
return await self._call_worker(name, *prepared_call.args)
File “/usr/lib/python3/dist-packages/middlewared/”, line 1331, in _call_worker
return await self.run_in_proc(main_worker, name, args, job)
File “/usr/lib/python3/dist-packages/middlewared/”, line 1246, in run_in_proc
return await self.run_in_executor(self.__procpool, method, *args, **kwargs)
File “/usr/lib/python3/dist-packages/middlewared/”, line 1231, in run_in_executor
return await loop.run_in_executor(pool, functools.partial(method, *args, **kwargs))
middlewared.service_exception.CallError: [EZFS_IO] Failed to import ‘tank’ pool: cannot import ‘tank’ as ‘tank’: I/O error`

I googled the error and found the way of importing in CLI with zpool. When I tryed to import the following error came up:
Screenshot 2024-05-23 184224
I even tried with -fF but still the same error. What could I do to get the pool back online?

Try zpool import -Fn tank and zpool import -FXn tank

-n is a dry-run, will tell you whether or not this should work
-F “attempts to return the pool to an importable state by discarding the last few transactions”
-X “Determines whether extreme measures to find a valid txg should take place. This allows the pool to be rolled back to a txg which is no longer guaranteed to be consistent.”

I tried the comands in the web CLI nothing has happend
Screenshot 2024-05-23 221535
So I tried the zpool import -FXn on the NAS itself, and this came up

there where multiple of these always with longer times. I looked the INFO message task middlewared blocked up but didnt find any solutions that made sense to me

sorry for beeing stupid cause of enter errors while tring to get a new line
Small Update:

I retried to use the zpool import tank -fFXn after switching the connected ports and now I get the error: “one or more devices is currently unavailable” but if i use the zpool import all the drives show up as all drives online just as before.
The zpool import tank -fFXn runs for like 45 minutes the drives have a kind of weird behavior