Cannot install paperless-ngx from community plugins

I’ve tried installing the paperless-ngx plugin and receive the following error code. Does anyone know a setting or adjustment I can make to get it to work.

Error: docstor had a failure Exception: RuntimeError Message: pkg error: - py39-scikit-learn : Refusing to fetch artifact and run! Partial plugin destroyed

fyi, docstor is the name of the jail

I tried to run paperless-ngx in a sandbox (Linux container) with the feature add in scale 24.04. I tried transferring my docker compose stack and ran into an error about unpaper not being installed and insecure memory. I am still trying to troubleshoot and determine the issue.

Same issue and exactly the same error message.

I was able to fix this by adding a capability option. I found it through searching the forums, but can not find it now while on my phone. Will post it here when I get home and look at my config.

Edit: found the post here Linux Jails - Experimental Script | Page 8 | TrueNAS Community

You need to add the CAP_IPC_LOCK capability. The following link for the manual page has other information capabilities(7) - Linux manual page

1 Like