Can't access GUI from LAN, wireless works?

Hi all,
I’m super new to TrueNAS. I’m playing around with it on an old Cisco 1u server, just seeing how I like it, and also so I can have a little experience with it, in case any of my clients use it in the future.
I’ve installed the latest TNS (, and the first thing that struck me was how looong the install took (~2hrs), and how slooow the boot is (~12min). Is this normal?! I have TNS installed on an internal HyperVisor riser, on an SD card. The system previously had ESXi installed the same way, so I assume this is all fine?
Anyway, now that it’s finally booted, and at the standard ‘ready’ menu, I have an IP to try to access.
However, when I try to pull up the webGUI on any browser from my desktop, I get some variation of “that took too long”.
Not “we can’t find that address”, you’ll note.
I can ping the server no problem from cmd.
Oddly, if I try from either my android phone or iPad, the GUI comes up, but it does take a long time to load the portal.
I do have a pfsense firewall/router on my network, but I don’t know of any reason why it would be blocking internal LAN traffic, unless TNS is doing something sketchy. No other internal traffic has any issues.
Any ideas what might be happening here?

You’ll need to describe your network setup…
Ip addresses, subnets, default gateways…

Nope. Are you installing it to a floppy?

Yup, that’ll do it.

Okay, so there is connectivity. I can’t 100% remember if SCALE uses http or https with a self-signed cert by default. Does your browser have something like always-on-https mode enabled? Can you try manually specifying http[://]x.x.x.x/ ?

This confirms the WebUI is at least working, so you’ve got some sort of issue between your machine and TrueNAS. Considering you can ping it it’s probably not a network issue.

Out of curiosity, can you cURL it from the machine having issues?

ESXi barely writes to the boot disk and is quite a minimal os.

TNS writes to the boot disk during operation (logs) and is especially chatty in 24.04.1.x (a bug?)

I would not run it on an SD card… I suspect it will burn out the card.

Is this a clean install with an empty pool ?

Yeah, I realized (a bit late) that TrueNAS is way different than unraid (my daily driver OS). lol
I’m used to installing the OS on flash media, and reserving all the storage drives for…storage. I missed the small, but critical, point of needing to install TNS on something quicker.
Anyway, that’s all fixed now. I reinstalled on an SSD, and the speed issues are all resolved. The connectivity is still a problem, though.
I’ve tried expressly typing http:// and http:// but neither will connect from my desktop.
I’m not really familiar with curl. Can you suggest the proper syntax? My LAN IP for TNS is
I tried simply “curl” and received back: “curl: (28) Failed to connect to port 80 after 21063 ms: Couldn’t connect to server”.
Actually, that might be a clue. I believe my unraid server (also on this LAN) is using port 80 for something else. Could that be the issue? A port conflict?

Yes, totally clean, no pool set up yet.

Okay, that discounts a few issues then

I also just discovered that I can reach the GUI from truenas.local via my desktop.
What does that mean, when the domain works but not the IP?

I assume it means teh domain is pointing to a different ip

if you ping the domain it should show you the ip its pinging

you you can dig or nslookup the domain. Depends on your platform

1 Like