Can't Access SMB Home Share

Hi all.

I’m fairly new to TrueNAS Core and NAS as a whole, so sorry in advance if the error I’m doing is pretty obvious.

Basically, I’m running TrueNAS on Virtualbox, I’ve set up a Home Share once and got it working. However, recently I started remaking the pool from scratch and I got to making the Home Directory but it simply can’t access it with the users i’ve set up in the ACLs.

For example, when I create UserA, it has its own share created automatically by the Home Directory but can’t access it when I try to connect to it via the network. I’ve gone through the ACLs and tried giving the group UserA (and even the user specifically) is in full access but by no means can I access it.

Any help would be greatly appreciated!

Hi, have you check under Sharing - Windows Share (SMB) if folder are sharable and enabled?


The Windows Share is enabled and it’s sharing.
I can see it when I access my Pool with UserA, I just can’t access the home share.

Have you already try to apply ACL permissions recursivly?
Maybe some screenshot of setup can help troubleshooting!

I’ve tried that as well and it hasn’t worked, restarted a couple of times too…
Here’s a couple of screenshots.
They show the ACL configuration (Using the default HOME preset, no changes at all), SMB configuration, the pool and finally the user in question, which is called Admin. (I’ve also tried with a second user and it won’t work.)


As you can see, I can see the Home Share created, but when I try to access it, i’m given the following error.

“\\Admin is not accessible. You may not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions.
A device connected to the system is not working.”

I’ve tried giving the user full access and it doesn’t seem to do any difference. :frowning:

Any ideas?


Well I might’ve just found out why it wasn’t working.

The dataset that was being used for the Home Directory was not set with a “Share type” as “SMB”.

I ticked it on and it works like a charm!
Thanks for the help anyways!
If the problem does persist, I’ll be sure to let you know. :smiley: :+1:

1 Like