Can't disable dhcp to add network bridge

Ok, so I was going through the guides on how to add a bridge interface so my vm can access my nas. I have a single interface in my machine so I need a bridge. The guide makes me disable my dhcp which is a problem as then, how am i meant to be able to access my server? My router assigns ip via dhcp so i am unable to access my server unless it can act as a dhcp client. Is there a way to get around this?

You’ll need to set a static IP. That would be done in the “Alias” box of the bridge config.

so to confirm my exact settings would be no dhcp in the main or bridge interfaces and an alias in the bridge that can be accessed from my network as a whole?

Correct.

thank you so much. Sorry for any inconvenience with a stupid question. I really don’t know much about networking or even linux and its hard to find time to research it all with studies and things.

No problem. I was on once in the same position. We need to help each other out.

Let us know if you fixed it this way.

1 Like

For future reference, I run through the process and provide some theory in this video

TrueNAS Scale: Setting up a Static IP and Network Bridge // Access NAS host from VM

1 Like

slight issue, my apps no longer seem to be able to access the internet, is there a way to fix this?

Did you select the bridge in the Apps → Settings → Advanced Settings dialog?