Can't update to Dragonfish from Cobia


I tried updating my TrueNAS Scale from Cobia 23.10.2 to Dragonfish When it’s done and rebooting I’m getting this error : kernel panic - not syncing: Fatal exception in interrup

I can boot on the old cobia 23.10.2 without any issue.

Here my hardware:
Motherboard : Asus Z170-A
Intel i7 6700k
Asus rog strix GTX 1080

Os disk : Samsung SSD 850 Pro (500GB)
first miroir : 2x TOSHIBA_HDWG460
second miroir : 2x HGST_HDN726060ALE614

So far, what I’ve tried :
I removed the GPU but still the same
I removed all disk except the OS disk.
I can’t even boot on a bootable USB for a fresh install of dragonfish
I tried other OS without any issue.
I reset all BIOS settings (and my firmware is the latest) but the issue still the same.

I’m running out of idea of what is my problem here. My only thought is the linux kernel 6.6.29 (that comes with dragonfish version) is not compatible with my hardware.

Any suggestions?

Do you get the same kernel panic when trying to boot up a USB with an ISO of Debian (with the same kernel)?

Hi, I’m really new to linux so I don’t know a lot of distros. Do you have any suggestion that I can try?

You could try a Dragonfish nightly which is using newer kernel to see if it’s already resolved.

If it is, try manually upgrading to 24.04.0 instead. The 24.04.1.x kernel has had some startup issues.

So I’ve tried 24.04.0 and 24.10 manual update and I got the exact same error on boot