Configuring apps for the first time, process never ends


I’m totally new to TrueNAS-SCALE-23.10.2, coming from a Synology 1515+. I have installed TrueNAS Scale on a 128Gb SSD Mac Pro 2009 that I have with 32 Gb of RAM and I put, for now, 3 older 1.5Tb HDD I have left. It is for my personal usage only.

For now I’m exploring my options with TrueNAS, before I try moving away from my Synology as my main NAS, and one of the things I really want is to be able to configure apps, such as Plex/Jellyfin, File Browser and probably more eventually, on that server.

But when I try to install an app or even just turn the app services on, I get a spinning wheel with that message:

Initializing Apps Service
Application(s) are being initialized

But this never finalized the setup, even after many hours. I reinstalled everything from scratch yesterday, and still gets this. I unset the pool, deleted the ix-applications dataset, reenabled the pool, same thing. Is it something I’m doing wrong or it is a bug or something I forgot to do before enabling the pool? anyone can help me?

Thank you


I’m on the same version and experience the same behaviour. Only difference for me is that this was not a first-time setup for me.

I just noticed that none of my apps were showing in the list on the apps page but they were still running so I went to unset my pool and rechoose it again but after multiple tries and several reboots either during the initialization (because it was obvious that it was stuck) or between unsetting and choosing the pool it doesn’t go past “Initializing Apps Service”.

The configuration and ix-applications dataset are still there and my list of apps returned and during the whole deal they are set to deploying but I doubt that they are actually deploying while the apps service is still initializing.

Is it a very strange bug or behaviour… I wanted to test something new, so I unset the pool, the spinning wheel with Initializing Apps Service still going on after that, then I remove the dataset ix-applications, same thing, rebooting, same thing again! really, it is stuck in a strange way…

oh, so I read that sometimes, it is a browser cache issues. Clearing the cache can help. I also found a post on the old forum telling users to uncheck/check the GPU (or another parameters) in the advance settings can help reset the system. So far, I have been able to start it now and can finalize my testing before migrating everything!


I had no luck with that method unfortunately, thanks for the tip though.

I ran systemctl status k3s to find out what’s going on with k3s and got the following:

● k3s.service - Lightweight Kubernetes
     Loaded: loaded (/lib/systemd/system/k3s.service; disabled; preset: disabled)
     Active: active (running) since Mon 2024-04-22 10:28:30 CEST; 23min ago
    Process: 197500 ExecStartPre=/sbin/modprobe br_netfilter (code=exited, status=0/SUCCESS)
    Process: 197511 ExecStartPre=/sbin/modprobe overlay (code=exited, status=0/SUCCESS)
   Main PID: 197512 (k3s-server)
      Tasks: 160
     Memory: 1.0G
        CPU: 53min 24.809s
     CGroup: /system.slice/k3s.service
             ├─197512 "/usr/local/bin/k3s server"
             ├─197684 "containerd "
             ├─197924 /mnt/nymph/ix-applications/k3s/data/dd1d3d06071c2bdb0c328f7fa183af844019354e937e8b15d529f1f828826bf8/bin/containerd-shim-runc-v2 -namespace -id 8aec1216c30cfd5218a7c991a7a836cda53f2ad3d0fb8144bc8773f153501178 -address /run/k3s/containerd/containerd.sock
             └─197967 /mnt/nymph/ix-applications/k3s/data/dd1d3d06071c2bdb0c328f7fa183af844019354e937e8b15d529f1f828826bf8/bin/containerd-shim-runc-v2 -namespace -id 0b17af0fce4173c86f7c1d5c27ba8855ee1b5a5fa41c9429d9b98177afe5d721 -address /run/k3s/containerd/containerd.sock

Apr 22 10:52:06 truenas k3s[197512]: I0422 10:52:06.033880  197512 trace.go:219] Trace[1046206990]: "Update" accept:application/vnd.kubernetes.protobuf,application/json,audit-id:4b97e163-90be-4140-8df6-f7bfd9923301,client:,protocol:HTTP/2.0,resource:leases,scope:resource,url:/apis/>
Apr 22 10:52:06 truenas k3s[197512]: Trace[1046206990]: ["GuaranteedUpdate etcd3" audit-id:4b97e163-90be-4140-8df6-f7bfd9923301,key:/leases/kube-node-lease/ix-truenas,type:*coordination.Lease, 601ms (10:52:05.432)
Apr 22 10:52:06 truenas k3s[197512]: Trace[1046206990]:  ---"Txn call completed" 600ms (10:52:06.033)]
Apr 22 10:52:06 truenas k3s[197512]: Trace[1046206990]: [601.170988ms] [601.170988ms] END
Apr 22 10:52:06 truenas k3s[197512]: E0422 10:52:06.119219  197512 kubelet.go:2475] "Container runtime network not ready" networkReady="NetworkReady=false reason:NetworkPluginNotReady message:Network plugin returns error: cni plugin not initialized"
Apr 22 10:52:11 truenas k3s[197512]: E0422 10:52:11.120201  197512 kubelet.go:2475] "Container runtime network not ready" networkReady="NetworkReady=false reason:NetworkPluginNotReady message:Network plugin returns error: cni plugin not initialized"
Apr 22 10:52:13 truenas k3s[197512]: I0422 10:52:13.716358  197512 trace.go:219] Trace[474850217]: "GuaranteedUpdate etcd3" audit-id:,key:/masterleases/,type:*v1.Endpoints,resource:apiServerIPInfo (22-Apr-2024 10:52:12.938) (total time: 778ms):
Apr 22 10:52:13 truenas k3s[197512]: Trace[474850217]: ---"initial value restored" 388ms (10:52:13.327)
Apr 22 10:52:13 truenas k3s[197512]: Trace[474850217]: ---"Txn call completed" 389ms (10:52:13.716)
Apr 22 10:52:13 truenas k3s[197512]: Trace[474850217]: [778.040509ms] [778.040509ms] END
lines 1-26/26 (END)

But I’m not sure how I’m supposed to fix this now. I would rather not have to setup all my apps again.

Booting back into did the trick for me and the apps service is running again.

Edit: And it’s back to not working again. Seriously, I’m this close to just wipe TrueNAS from my server and just use something different. This is frustrating.

My joy was short live so far. I was able to install File Browser, but when I tried to install Photoprism or add TrueCharts catalog, that did not worked at all so far.

I face a kind of hit and miss, but since yesterday, I have been able to configure a few apps from the store. I also realized that even if I was thinking the TrueCharts catalog failed to install, it install in the end. So far, I have not been successful installing apps from that catalog yet. So still exploring things before I prepare everything to make the big move!

You can try the following. I have found in Scale that you need to actually have root enabled and be logged in as root to install apps properly. Sometimes an app will install when logged in as admin, but no guarantee.

In Credentials >> users if the root user is not enabled (it may not be), then give root a password and enable the root user. Log out and log back in as the root user to the TN GUI. Uninstall and select Remove data from any apps that failed or partially installed. Remove any data sets and app config data that you may have left over from the failed apps In apps >> installed apps settings >> select the Manage Container Images and remove any images from the list (part of the container tag will show the app name) form any failed app installs. Re-create any app config dataset you may have had if you did that. Refresh the apps and proceed to configure and install the selected app. It should now install and configure and deploy without issues.

If the app database won’t refresh or an app cannot pull the container info then you may have a dns issue or an issue accessing the web outside your local network that needs investigating.

1 Like