Connecting to TrueNAS… WebUI Issue on 2 Servers!


This is a very weird, but hopefully unique post that we all can learn from!

We have 2 TrueNAS servers operating with about 80TB of sensitive data. Both WebUIs were operational with no errors last night, but this morning we tried signing in and BOTH servers are throwing the same WebUI error:

“Connecting to TrueNAS … Make sure the TrueNAS system is powered on and connected to the network.”

Why would both servers all the sudden throw this error?

I can SSH into the servers and I can still read/write to the drives from my other servers, but I cannot sign into the WebUI.

Things I’ve done:

  • Restart NGINX
  • Restart middlewared
  • Restarted both in different sequences

I cannot even dump the config due to this apparently needing over “100 lines of code” to do effectively, but I know there’s an internal API to dump the config and keys

I will pay for the solution at this point. I cannot afford to lose or mess up any pools. These servers are serving a lot of data, so I’m looking to fix the first system with less data before touching the big boy!

Please let me know of any questions and I’ll be happy to check! Again, I can SSH into the servers

EDIT: I have done the following since writing this -

  • Updated the DNS to ping TrueNAS update servers
  • Set System Time correctly
  • Rebooted
  • Checked the SHELL after a reboot and no errors being displayed

After reading a lot into this, could it be a corrupt SMB share? It doesn’t seem like a certificate issue at all


Final Update: Turns out it was bitdefender blocking TrueNAS certs. After I uninstalled bitdefender on some nodes, we were able to access the WebUI… We’ve emailed IX Systems with this report as well

Simply reinstalling Bitdefender allowed the certs to be “okay” again. It wasn’t our Bitdefender policy because nothing was ever modified on it and when we re-installed Bitdefender after an engine upgrade, it worked again.


1 Like