Connection Issues: Enabling Direct Access of VMs in TrueNAS to ESXi vNICs

I installed TrueNAS on VMWARE with two virtual network adapters connected to the same PORT GROUP. The first adapter is configured with IP 172.25.11.x/16. Now, I want a VM within TrueNAS to have access to the second network adapter of ESXi, but I’m having trouble doing so.

I’ve already searched through several sites, but the most I could achieve was creating a bridge and assigning another subnet within the VMs inside TrueNAS. However, this is complicating things for me because I want to install Nextcloud and expose it to the internet. Therefore, ideally, the VM within TrueNAS should have direct access to the ESXi’s vNIC without using the bridge.

Additionally, I’m struggling to understand how the VMs within TrueNAS can access the vNICs of ESXi. If anyone could provide an explanation, I would greatly appreciate it.

Why? That makes very little sense.

I did this because it’s a testing environment, I don’t currently have another physical machine. I know this isn’t the ideal or best of worlds :frowning: it’s the environment I have at the moment, and if the tests work, I can request the purchase of a new server to install TrueNAS bare metal.

Dear all,

I understand that virtualizing a machine within ESXi might not seem to make much sense initially, but in corporate environments, it certainly does, whether for testing or real applications.

This was the first topic I opened and I confess I was about to give up, as I managed to configure NEXTCLOUD directly on TrueNAS using the native TrueNAS app, since it already had a bridge to Docker with external access.

However, I was not satisfied because I wanted to conduct more application tests on the VMs of TrueNAS virtualized within ESXi, but without access to the external environment, it would not be possible.

Solution found:

For the TrueNAS bridge to have access to the external environment, I had to enable the following options within ESXi:

  • Promiscuous mode
  • Forged transmits

As shown in the image below:

I had already encountered this when testing GNS3 within ESXi but had forgotten about it, and after spending a lot of time, I came across the same solution again.

Additionally, to help other users who encounter the same problem, here are the configurations for my bridge and the VM within TrueNAS. You don’t need to assign an IP to the bridge, and I set the VM to DHCP so it would obtain an IP directly from the main network where the ESXi is located.

1 Like