"could not malloc 163840 bytes..." error during instilation

I’m trying to install TrueNAS Core, and while trying to boot from the USB, I get this:

What should I try? thanks

Motherboard is a M5A78L-M/USB3
installing from a usb drive.
system has a sata ssd, and two sata hdds.
16gb ram
amd fx-4350 cpu
nvidia gtx 970 gpu
Intel EXPI9400PTBLK Pro/1000 NIC

iso = TrueNAS-13.0-U6.1.iso

How did you create the boot medium? Try balena etcher if you used something else.

Is the SSD to which you try to install clean or was it used before for another OS?

While not impossible that this was due to a corrupted boot drive, I’d definitely start by looking into how much DRAM is actually showing up to the OS and/or system firmware. Seems to be pretty early in the boot process, so check what the setup menu reports as installed memory.

yes, i created the boot medium using etcher. it verified ok.

the ssd has been used before but has been wiped and is now completely clean (no partition table). however,this is very early in the boot process, so i’ve not been able to attempt any installation yet

the bios reports 16gb.

it does seem very early in the boot process.

i’ll try recreating the installer usb when i get chance tomorrow, but etcher did complete the verification ok

Another thing to try if nothing else works, and this might sound “out of left field”:

  • Try it with SCALE
  • Try it with vanilla FreeBSD

If it boots up properly with SCALE, and allows you to proceed to the installer, but you cannot proceed to the installer with vanilla FreeBSD, then it’s likely to be a different issue other than RAM.

SCALE boots:

FreeBSD doesn’t boot:
(“FreeBSD-14.0-RELEASE-amd64-dvd1.iso” written to USB drive using Etcher.
“FreeBSD-14.0-RELEASE-amd64-memstick.img” gives the same message.)

That’s what I suspected.

I haven’t been able to boot up (to the installer) with either FreeBSD or TrueNAS Core on some computers.

I was never able to pinpoint this peculiar issue, but the FreeBSD forums might be able to provide some clues.

what is different about SCALE that makes it work?

Do you think it’s worth me trying older versions of CORE?

The GPU and NIC are new to me so they are a bit on an ‘unknown’ - do you think these components could be the cause of this?

SCALE is Linux (Debian).

Core is FreeBSD.

I also tried CORE version “FreeNAS-11.2-U2.iso” and got this error:

Memtest shows ram:

Installing SCALE also fails:

I wonder if this might be because my motherboard is a BIOS motherboard, and I need to select the BIOS workaround in the SCALE install process?

It’s too recent not to be EFI.

Why not simply use the default EFI boot when prompted?

1 Like

Thank you! It works!!

I was checking in the motherboard user manual, and there is no mention of “EFI”, only “BIOS”. This is why I mistakenly selected to use the bios workaround.

CSM strikes again, creating problems where there are none by pretending to be an IBM PC AT, so that you can run checks notes Windows 7, which has been out of support for some five years…?


In the end, I used a USB2.0 4gb drive, rather than a 256gb usb3 drive, and it worked.

Oh, come on…

Marking your own post as the “solution”, after the proper solution already resolved it? :wink:

But it is the solution! I want to use Core, not Scale.

However, the core installer is asking if i want to use uefi or bios boot mode, and it seems to be indicating that bios is the recommended option?

What should I select?!

UEFI if it can be made to work on your system.

i tried it with uefi boot mode and it didn’t work. Bios mode does work