Credentials > Local Users > User form: "Path has the ZFS readonly property set."

Hello there, all,

Dragonfish- here.
I am very new to the whole TrueNAS and ZFS worlds. Not sure what is happening, I’d rather get some insights from knowledgeable people, hence this question. :slight_smile:

In Credentials > Local Users, I am trying to edit some already-existing user (I want to check “SSH password login enabled” for those). Unfortunately I am unable to save the change: when clicking the “Save” button", an error message is displayed under the “Home Directory” box, stating Path has the ZFS readonly property set. (in a red-colored font).

When checking the path (e.g. /mnt/nas/home/user1), the readonly ZFS property is set to off on the whole dataset (“nas”, mounted on /mnt/nas).

So, what could I possibly miss here? Any help or hint would be much appreciated!

Not sure if you checked this directly or not as the wording is little confusing. Child datasets can have a read-only flag that do not inherit from the parent. You should be able to check in datasets → edit dataset → advanced.

If you’ve something like replication, you might have forgotten to uncheck the box that marks the dataset as read-only.

I checked using both the command line (zfs get readonly nas shows off in VALUE column) and the web UI (Datasets > select nas dataset > click Edit in Dataset Details > click Advanced Options in the Edit Dataset form: Off is shown under the “Read-only” label).

If I am getting it right, this dataset has no child (assuming that I should see a “expand” arrow left to its name in the Datasets screen if it had ay child)… so this property could only be defined at the “nas” level, right?

I tracked down a potential avenue for this validation message to erroneously appear if there are RO bind mounts for the dataset hosting the home directories.

1 Like

Indeed, I have set up a read-only folder structure by setting a bunch of read-only bind mounts from various folders under /mnt/nas/share/user2 to subfolders of /mnt/nas/share/share_ro. Based on your input, I could work around the issue by unsetting the bind mounts, modificating the user the way I wanted it, then bind-mounting again. Thanks!

Shall I report this bug, or would you rather do it yourself, @awalkerix ?

I already have a WIP fix for it, but will not be in the upcoming 24.04.2 release.

1 Like