Delete "System Volume Information" folder

Went through
to import data, and what resulted were the folder/files i was expecting as well as a recycle bin folder and “System Volume Information” folder that i can’t delete; anyone else run into this issue?

I’ve already changed permission recursively via Permissions | TrueNAS Documentation Hub

System Volume Information is a folder generated by Windows. I forget exactly what it is for, I think it’s something with recovery. As such, it has special flags also to prevent accidental removal.

Which permission model is the dataset that contains this folder using (UNIX or Windows ACL)?

You cannot delete it, even as the root user or with sudo?

I believe ACL as that’s the tags that appears when i’m updating read/write permissions after an import

Go to the shell and type in getfacl "System Volume Information". You should be able to see the permissions on it and we can potentially get rid of the protection flags so you can delete it.

I suspect, it may be as simple as setfacl -b "System Volume Information" and you should be able to delete it as root.

It says root@truenas[~]# getfacl “System Volume Information”
getfacl: System Volume Information: stat() failed: No such file or directory

I tried other folds and it results in the same error, is there a guide to list/navigate the folders/directors that are available? the search results i’ve found weren’t too helpful.

You have to navigate to the dataset that has that folder first. It’s likely located in /mnt/pool_name/dataset_name

Use ls command to see the directories of where you are and cd command to change to that directory. Use tab key to help auto-complete your entries.

hmm when i type in ls u get a but of . stuff like .ssh and .warning as well as samba and syslog

and when i try /mnt/Sea14/Sea14Data it says permission denied. I’m logged in as root and the permissions i gave earlier were for a user group i set up for the windows share that shouldn’t interfere right?

Does it help if I do it with you like this? I think you’re just getting stuck with syntax errors in bash.

root@prod[~]# cd /mnt
### All pools are mounted inside of /mnt
root@prod[/mnt]# ls
ice  optane_vm
root@prod[/mnt]# cd ice
#### I want to work in the ice pool
root@prod[/mnt/ice]# ls
frigate_storage  nvr        timemachine  vms
media            nfs_test   slow_test  
root@prod[/mnt/ice]# cd media
#### I want to work in the media dataset

Now lets go, in your example to the correct folder. You can probably type the letter S for System and then tab for completion of the path when you are typing cd.

Then you can do getfacl . for the current directory

root@prod[/mnt/ice/media]# getfacl .
# file: .
# owner: FUSCO\\nickf
# group: FUSCO\\domain\040users

Yes that worked to get there, much appreciated, downside is that it seems that all permissions are already allowed?

file: .

owner: SubRoot

group: SubRoot


root@truenas[…/Sea14Data/System Volume Information]# getfacl

Please make a checkpoint of your pool (or a snapshot of the relevant dataset) before you issue any “delete” or “rm” command(s).

It only takes a second, and it can be discarded after you’re done.

Will do, but for better or worse i’m still in the learning stages of getting everything set up and transferred so if I have to start over from a reinstall, it’s not a big deal.

I was able to navigate to the folder with NICKF1227’s help, but even after using the setfacl -b "System Volume Information" command still couldn’t delete the folder,
but some permissions did change

What is the syntax and parameters of the rm command you’re using?

Setfacl is a tool to set file system permissions. Rm is a tool to delete files and folders.

You wanna do rm -f /mnt/pool/dataset/foldername

Insert Spider-Man reference. I am not responsible for your data.

Need to include -R for a recursive delete, hence to delete folders.

Idk why I typed f. Yes this


So maybe you’d want to do something like

cd /mnt/Sea14/Sea14Data
setfacl -b "System Volume Information"
rm -rf "System Volume Information"/*
rmdir "System Volume Information"

Steps 3 and 4 could really be combined into 1 step, but the way of doing this is much safer and runs less risk of you deleting wrong things unintentionally.

That worked! thanks you Whattteva @NickF1227 @winnielinnie for your help!
I’ll probably need to do this again after i import the next disc and another similar folder shows up