Deleted snapshots - apps gone

For some unrelated reason, I had to move a lot of data from one dataset to another in the same pool, which filled the pool completely because of snapshots. Thus, I deleted a lot of snapshots before comming across some advice to never delete the snapshots of the ix-applications dataset - which I already did (at least for some). A few hours later, my installation is back to normal, except for the apps I installed having vanished from the UI :frowning:. They did show up briefly after the initial re-starting though, but then disappeared. I only had 4 apps installed, of which I would very much like to restore at least one (photoprism, as I had a lot of tagged faces and some albums I’d rather keep). What can I do to fix this?

The ix-applications dataset still seems to contain all data, but no apps show up. I only found one similar topic, where the advice was to use truetool to mount the pvcs, so I tried using HeavyScript, but heavyscript pvc -m does not list any apps.

Like I wrote, I actually only care about my photoprism “metadata”, which should all have been stored in its database or its config files. If I could at least restore this data, I would be very happy :slight_smile:

I turned to the TrueCharts Discord, where I received help. It turned out that the apps service wasn’t up and running properly, despite the WebUI saying “Apps Service Running” next to a green checkmark. We verified that by running sudo k3s kubectl get pods -A, which returned the following:

root@TrueNAS[~]# sudo k3s kubectl get pods -A
E0430 10:28:27.566209 2832932 memcache.go:265] couldn't get current server API group list: Get "https://127.0.0.1:6443/api?timeout=32s": dial tcp 127.0.0.1:6443: i/o timeout

After that, I unset the pool (Apps → Settings → Unset Pool), waited 5 minutes for things to settle, then chose the pool again. This didn’t change the output of sudo k3s kubectl get pods -A, so I tried a restart - and lo and behold, the apps were back! After that, I uninstalled the old operators (Frequently Asked Questions (FAQ) | TrueCharts Charts) and installed cert-manager, cloudnative-pg and prometheus-operator again from TrueCharts as described in Getting Started | TrueCharts Charts. After adjusting some paths that changed because of the data move, my apps were working again.

Currently I’m migrating the apps as described in Cobia to DragonFish Storage Migration | TrueCharts Charts

1 Like