Difficulty establishing HTTPS (tls settings)

Good morning!

I’m having trouble configuring tls in apps.

All the videos, forums and tutorials that I studied show, under tls-settings, the option to select a certificate, but for me this option does not appear and I cannot assign my certificate to an app.

I have already configured Truenass and ACME certificates through Cloudflare. but without success in selecting the certificates in the apps.

I need help please.

1 Like

All the video tutorials and most guids not directly provided by truecharts are out of date. If you want to add a cert to an app you need two additional apps namely cert-manager and cluster issuer, which now provide the certs for their apps.
See clusterissuer Setup Guide | TrueCharts



I’m about a week trying by videos and tutorials.

Working like a charm using certmanager and clustetinssuer :grin:

You save me tks a lot.

If further support is possible… I configured DNS on Cloudflare to reach the app for internet like:

fb.mydomain.com - type A - point to my internal nas IP

I can’t access it outside my local network (web browser show ERR_CONNECTION_REFUSED)

Can you give me a tip please?

1 Like

Of course you can’t–your internal NAS IP is a private IP address that isn’t routable across the public Internet. You’d need to set that to your public IP, and then port-forward on your router, to make this accessible–but exposing your NAS to the public Internet is strongly discouraged.


I would like to expose only the Homeassistant app…

It’s not recommended?

1 Like

A-Record should be your public ip adresse, you can find it on pages like whatsmyip.com
For each app you then want to expose you have to create cnames. Those cnames then need to be added to the ingress section of the app you want to expose.
You also need Traefik as reverse proxy for it all to work and come together.


Is possible to use a app like ddns-go or similar to automatic refresh my ip?

My isp give me a dynamic :confused:

1 Like

Sure; IIRC there are several such apps available from the TrueCharts catalog.


I’m using the cloudflrare ddns app to automatically refresh my ip. There’s a setup guide on the truecharts website.


So I set up token API to refresh my dns on cloudflare.

Also I set my domains, like XX.mydomain.com, on ddns-go that already work and automatic edit de ipv4 to myu real ip.

But when I try conecting outside my LAN I can’t reach the apps.

Obs.: traefik recognize de app ingress https (websecure), works perfect on internal LAN.

Sry disturb, looks like a noob thing, I traying my best, smiles :sweat_smile:

1 Like

Your best bet would be the truecharts support on their discord, they’re far better at diagnosing problems then i am.
Since i never had problems during my setup i’m not the best to ask for troubleshooting :sweat_smile:



Just for information…

My ISP is blocking ports 80 and 443. It’s not a problem with my settings.

I have already filed a complaint with the regulatory agency here in my country (ANAC - Brazil).

Let’s see what will happen… Unfortunately in Brazil things are difficult.

1 Like