Disk unassinged, pool offline after fio

Hi all,

I run a few fio commands to test write speeds of my ssds. Unfortunately, I learned that after this the disks are not available anymore, thus the pool is offline.

root@truenas-scale[/home/admin]# zpool import
   pool: applications
     id: 11734411687122568160
  state: UNAVAIL
status: One or more devices contains corrupted data.
 action: The pool cannot be imported due to damaged devices or data.
   see: https://openzfs.github.io/openzfs-docs/msg/ZFS-8000-5E

        applications                              UNAVAIL  insufficient replicas
          mirror-0                                UNAVAIL  insufficient replicas
            4be538f8-3c73-4c98-a395-4e3c6b3fcee6  UNAVAIL
            nvme0n1                               UNAVAIL  invalid label

Appreciate your help to fix this.

1 Like

Did you try rebooting?

Yes I tried. Did not work

Can you please post the exact fio command you ran?

If it included a part similar to --filename=/dev/sdX and you used it on a drive with data on it, you’re probably SOL. In that case you will have to use a backup, if any exists. Even a snapshot won’t help you.

1 Like

Most likely you wrote over your data to test write speeds.

This was my command:

sudo dd if=/dev/zero of=/dev/nvme0n1 bs=1M count=100000 oflag=direct

Is there anyway to restore at least one of the 2 drives without reinitializing a full backup?

Okay, that’s not fio.
But the end result is roughly the same, you overwrote 100k 1M blocks of your nvme drive with zeros.

Did you run the command or something similar on both drives? I ask because you have two drives that show as UNAVAIL.

With the information you’ve given it really does sound like a restore from backup is the best practical way forward.

1 Like