Dragonfish broke Photoprism

After updating to Dragonfish… photoprism is stuck on deploying.
Using Truenas, but also tried Truecharts version unsuccessfully.

Startup probe failed: Get "http://xxxxxx:20800/": dial tcp xxxxxx:20800: connect: connection refused

Does anyone know how to fix this?

EDIT//
For anyone having this issue, I reinstalled the Truecharts version and changed the port number. It took forever to deploy, however it eventually loaded and is now running.

hi did you get the error message during deployment with Truecharts?

I was now able to install the Truenas version without changing any settings. (no host path). However, I can’t upload any pictures now. The upload starts. However, no images are taken over.

Truecharts returned some other erroneous message, however eventually deployed successfully. Haven’t tried uploading yet.

I did have to change folder permissions to full access.

I have installed the Truecharts variant. I didn’t change anything other than entering the password. And it works now. no idea why. The main thing is that it works properly.

Hi All. I tried installing Photoprism from Dragonfish app page.

Its stuck on deploying and I get this error message:

Startup probe failed: Get “http://172.16.0.32:20800/”: dial tcp 172.16.0.32:20800: connect: connection refused

I tried opening all the ports on my router, and giving the 3 folders it asks for during install (upload, storage, etc.) 777 chown permissions to the world.

Funny thing was the first time I installed it I actually got to the UI screen, but because I didn’t configure my folders correctly (and their is no way of browsing within Photoprism) I thought a fresh install would solve it.

Since then nada. Is there a trick to the folders, permissions, certificatel, port address that is causing this issue? I tried replicating what I did the first time. Are you creating a custom dataset beforehand?

This is vexing me.

Just curious Bob. Did you use in the chown check box from the install page itself? If so what code did you apply? Or did you create a dataset from scratch.

Never knew why Linux has to be deliberately this obtuse for no benefit whatsoever. Why can’t apps own the folders they themselves create? People wonder why windows won the fight.

Only gave the app group for photo prism full access in truenas permissions. Nothing fancy. I also did a hard restart on truenas. It was al existing app directory from the previous version.

First couple of times I received errors, however after all that, the install just worked on the final attempt.

Make sure everything is up to date first.

Thanks Bob. I never created an app group and I don’t want to break my plex install by messing with users / groups now. Just curious, what did you change the port to?