EATON UPS doesn't let computer to boot up

I’ve got an Eaton Ellipse Pro UPS connected via UPS to my TrueNAS system, and it is computer via USB. If it is connected, when I turn on the system it will enter a restart loop after about 10 seconds, but if I unplug and replug the USB, it will boot normally (and it will be detected by NUT and work normally). Tried a different cable and computer and the UPS works normally. EcoControl is disabled and I tried all the different sockets, and the other things plugged to the UPS don’t shut down.

The only thing that comes to mind is that before the system has an LSI 2008, which boots up before the main system bios, so the UPS might be getting confused or something?

Thanks for any help.

I have an Eaton Ellipse Pro with USB cable attached to my system and it works and boots just fine, and reports by email when a power outage occurs and when the power comes back.

I assume that you have flashed the LSI 2008 (or checked that it was previously flashed) to IT mode?

Nothing to do with an added card.

The UPS is simply sending the command to shutdown to the system.
Do you hear any noises or beeps from the UPS? Guessing not.
(noise=testing battery, beeps=low/bad battery).

This could be because the UPS is calibrating (on battery) for 15-30 secs, because the load is too high, battery low/old or specific settings in the NUT software that watches the UPS messages. (Selected correct driver?).

As always: Check the logs for clues. There has to be a message indicating the action that NUT took.

If nothing else, connect the UPS to a Windows machine and install the UPS driver and software so you can compare results and battery status, etc.