Emby Stuck at Deploying After Restoring Server from Backup

Hi all, I have my Emby server on an old MacBook Pro. However, I recently got a mini PC on which I installed TrueNAS Scale and want to switch my Emby server. I installed the official TrueNAS Emby app from the “Discover Apps” section (I have screenshotted my config settings for Emby below). In the settings for the Emby app, I added the dataset “emby” where my backup folder is located (the most recent Emby server backup being yesterday). On the first boot-up of Emby, everything went fine. I was able to access the webpage and set up the server like normal. I activated my Emby Premiere, went to the restore backup section, and added the backup folder with no issues. When I clicked “restore from backup” it gave me the normal pop-up saying that the Emby server would be restarted, to which I clicked ok. However, when I went back to my TrueNAS GUI after telling the server to restore from the backup, Emby was stuck deploying and would be so for hours. I have searched for hours trying to find a solution and nothing has worked. I tried disabling SMB share, I tried creating another dataset specifically for the backup folder, and then adding that to the additional storage in the config settings for Emby, I tried changing permissions on all the datasets to full permissions, and none of these things have worked. Has anyone else experienced this issue? How do I fix this?

I’m not sure how Emby Premiere is impacting things… can you do the same steps without it?

Do you have a mount point in the Emby jail pointing to the dataset?

In the Emby jail a mount point should be setup to allow “outside” data to be reached inside the jail.

In my Emby jail I have
source: /mnt/Media/Emby_media
destination: /mnt/Docs/iocage/jails/emby-server/root/media .

All the data is outside the jail, but Emby has full access to it.

Emby premiere shouldn’t affect things. I can only restore from a backup if I have Emby premiere.

1 Like

Jails aren’t available on TrueNAS Scale. At least I don’t think so…

Sortof are

If I’m understanding the way you have your emby dataset set up, you may need to mount a separate dataset for Emby Config Storage where you currently have your /mnt/tank/emby mounted (this could be an iXvolume instead of manually defining a host path) and then mount the backup data using the Add button next to additional storage.

I tried that, but I’m encountering the same issue. I left the config storage to the default storage without manually defining a host path and mounted the backup folder under the additional storage. (within the “backup” folder there’s a “Backups” folder which is where the Emby backups are located)

So I can create a jail in TrueNAS Scale in which I can run Docker? Sorry, I’m pretty noob with TrueNas

Yes. See:

In the future, Docker will be included with TrueNAS.

Currently, its possible to launch Docker containers with the Kubernetes app system on TrueNAS, but if you want to use Docker directly, or use Docker Compose, then the Jailmaker docker sandbox approach works today, and will be easy to migrate to whatever comes out in Electric Eel in the future.

Ok, I followed along with the video. Everything worked fine until the end. I got Dockge set up with Emby, but when I try to go to the port of Emby, it refuses to connect. I’m not sure what I did wrong. Also, I can’t access the nginx test container either.

Any suggestions on this problem with Dockge? @Stux

The terminal says that emby quit. Seems to have something to do with the SQLite database

@Stux how would I fix this? It’s not just Emby. It’s any docker container that I try deploying

When apps don’t fully deploy, or get stuck in deploying, you can try to access the pod logs to see what information it provides.
On the Installed applications screen, select the row for the app, in this case it is Emby, then scroll down to the Workloads widget (just under the Application Info widget, where you should see two icon buttons, one for the pod shell and one for pod logs.
Click on the logs icon button, accept the defaults for the Pods and Containers settings. If nothing is present in these fields, then the app might not have reached a point where it can show logs or the shell for the pod/container.
If you can access the logs it should tell you where the problem is when deploying using the TrueNAS UI.