Enable Change Notification TrueNas Scale

I need to enable kernel change notify in my truenas scale, but I noticed
Auxiliary Parameters are not on the smb shares anymore, and if I try to add parameters to /usr/local/etc/smb4.conf it is now a read-only file
Can anyone point me in the correct direction for this flag nowadays?
OS Version:TrueNAS-SCALE-

Do you mean inotify? That should already be enabled by default, and I believe the default Samba config already passes along those events IIRC.

We use it for apps such as Syncthing today, its how it knows when to wake up and sync files to peers.

1 Like

Yes, 100% inotify; over the years working with various vendors, I have had to do several things
change notify = yes
kernel change notify = yes
inotify and beef up watchers …
On Cobia. I didn’t have to do anything, and it worked out the gate. I was giving Dragonfish a trial run before upgrading to ensure nothing would be impactful. If you are saying it enabled out the gate and is passed along by default on my SMB shares to Windows, that’s 1 great to hear, and I’ll rewind my setup a bit and make sure nothing stands out as missing. 2 any alarm bells were I might have shot my self in the foot?

As long as you didn’t change things manually behind the scenes in samba configs, it should just “work” out of box. The only thing we tell folks to occasionally bump up is the number of watchers if they need more. The defaults on Dragonfish should be pretty decent for most users:


100% appreciate your knowledge and time…
I restarted my Truenas instance, and notifications are working. I’m chalking it up to something goofy post-install.

1 Like