Error: [EFAULT] Disk: 'sde' is incorrectly formatted with Data Integrity Feature (DIF)

Hello all

Due to my Stupidity I accidentally screwed my Trunas Scale installation.

I re-installed the latest download of truenas scale on on a supermicro x10.
i had installed 4 hgst 4tb drives and 3 wd 2tb drives (i know that one is faulty and this is why io was going to replace the 3 wd with 3 additional 4tb and add them as a separate vedv)

I wiped the 4 hgst and the proceeded to import the drives and create a new pool

all is fine until i get
Error: [EFAULT] Disk: ‘sde’ is incorrectly formatted with Data Integrity Feature (DIF).

When i try to use the truenas shell and admin@truenas i input
sg-format -v -F /dev/sdg
I get

error opening device … permission denied

How do i totally format these drives so i can add them to a new vdev

Thank you all for you time and help

You’d need root permissions to run this, so sudo sg-format -v -F /dev/sdg.


Thank you for you very quick reply

i will try this


Update I did proceed to format all drive and tried to create a new pool.

as i go through the process and select5 the drive and click on the create pool, the software comes back after a short while with the same error as above

i’m stumped

Well, there’s a lot missing, but I’d point to this to hopefully point you in the right direction:

According to this Reddit

You need to power cycle too.

Are these drives new?

@Stux thank you

these drives are 3 years old. i’m currently re-running the low level formatting that was suggested here above.

Each drives takes about 10 hours to format.

Thanks to @dan for his suggestion since my las post i only managed to format 2 drives and i’m about halfway done my third one now.

I looked at the link and personally i do not feel comfortable going the wd route

Thank you all for your help i will know tomorrow or thursday if i am successful