truenas doesn’t work, I’ve tried everything but still it shows the same error
after installation this is shown

what he was trying to do:
connect another disk
change disk in bios

processor: i5-2400 intel
graphics card: integrated
RAM: 2x 8 GB x star
disk: Samsung SSD 128 GB
bios version: PO1-A

  • Were you able to boot the TrueNAS installer? YES
  • Which version(s) of TrueNAS are you using? core
  • Onto what device did you install TrueNAS? pc
    Did installation complete without errors yes
  • Is the new boot device–the one you installed TrueNAS onto–still connected to your computer? no
  • Is it set as the boot device in your BIOS? yes

You can try two things and make sure you have a consistent setup:

  • install with UEFI boot only
  • set the BIOS to boot via UEFI only


  • install as legacy boot
  • set the BIOS to legacy only

One of these two at least should work. If neither does, I’d look for a BIOS update first.


install with UEFI boot only how?

Doesn’t the installer let you pick either UEFI or legacy/BIOS boot? Sorry, it’s been a while. The standard FreeBSD installer sure does.

EDIT: my TN CORE as well as my TN SCALE systems are all installed with only an EFI partition and no legacy boot one. So either that’s the only option already - which I doubt - or the installer lets you pick.

Anybody who knows from the top of their head?

The boot device isn’t connected to your machine??
I’m assuming this is a typo, otherwise it is kind of obvious that it won’t boot.

It does not let you select (as of my most recent look a couple months ago)
Select Install → Select boot-pool disk(s) → Confirm erasure → Set admin password → Create swap partition → Reboot into TN. I don’t believe there are any ‘advanced’ options (you can drop into a shell, but I’m not counting that)

EDIT: just gave this a quick scrub through to confirm

Get it. For me that’s a good thing since I have been installing everything as EFI only wherever I could.

Now the only unanswered question is if it would support legacy boot and e.g. install the appropriate boot loader partition depending on the way the installer was booted at the beginning.

That might be it. I think if you boot the installer via legacy, then maybe you get the choice to install legacy or uefi.

I definitely played with this just last week while installing demo scale VMs.

(Ps: the installer does not support virtio ;))

Or was that core. It’s confusing :slight_smile:

(I won’t delete this one although i probably should)


I just tested this in a VM on Cobia.

With both Legacy BIOS or UEFI bios using Dragonfish 24.04.0, you get prompted with the Legacy Boot screen.

Its the last screen you see before the actual install starts after you pick root/admin/no for admin user.


The error message feels to me like it is saying you are trying to boot in UEFI mode but you installed TrueNAS in legacy mode.

As suggested by @pmh, if your BIOS supports UEFI, set it to use either ONLY legacy or only UEFI boot and not either.

IMO if your BIOS supports UEFI, you should set it to use only UEFI. Period.

Then install TrueNAS.

1 Like

This doesn’t really provide any info.
Did you do the change suggested by @Protopia?

I don’t know how to do it in my bios

This is interesting, I reinstalled just a couple of days ago and didn’t see this as an option. I wonder if this only shows in x circumstance, like if UEFI with CSM is in use.

Well, your motherboard model isn’t mentioned so we can’t give you any real pointers other than Google. There should be plenty of guides that will show you how to do this.

I tested using a VM hosted on TrueNAS. Eitherway, I got the screen, but it happens as the final prompt after the install process “begins” (ie when writing starts being written to the screen.


s the new boot device–the one you installed TrueNAS onto–still connected to your computer? no

Umm why is the boot drive not connected?

On some systems, the BIOS may mess up the boot order. I have one such system that can act this way only under certain conditions…
One way to see if the machine can boot is to remove all drives except the drive you know is the boot drive. Then boot the machine. If that works then that was what was wrong. Also make note of the serial number of the drive as if the Bios messes up the drive order again you know which one to set in BIOS as the boot drive.

I have also read where some BIOS and an auto type setting for booting either Legacy or UEFI. If it supports UEFI then set to UEFI only in the BIOS. It makes things much happier


Try remove all boot device you dont need from boot priority order, then check the hard disk priority from the only menu available pressing enter, and try reboot

I can’t set it up like that

This is what i mean, it help me do the same on an old h61 mainboard that have the apparently the same options