Finally figured out how to stop WMSRS or MSRS error spam from KVM

modprobe kvm report_ignored_msrs=0 ignore_msrs=1\modprobe -r kvm_amd\modprobe -r kvm\modprobe kvm_amd\modprobe kvm

Add this as a post init script if on AMD. on intel it’d be kvm_intel.
What this does is forces report_ignored_msrs=false option which is by default true.

You have to then reload the kvm module post init, but it does not interfere with VM startup as it’s done quickly.

1 Like