First RZ2 Scrub -- 117% complete and increasing

Only had TrueNAS for about 2 weeks so this was the first scrub ever and the first (very old) results I get from Google induce a lot of concern… Besides waiting for a “Scrub Complete” message, what suggestions do you have? The % complete and remaining time keeps increasing by the minute :exploding_head:

I stopped all applications, completed any/all file transfers, and even restarted the NAS before starting the scrub. During the scrub (~18 hours so far) I made it a point to have near zero interactions with the NAS. I can still see my SMB files, but haven’t tried opening anything.

The drives are recently purchased (oldest ~6 months) and were manufacturer recertified – have not used the TrueNAS SMART check yet.

On a side note, I had to set the threshold to 0 days because it passed the previously set time while taking zero action. There is not a “Run Now” button for the first ever scrub task.

P.S. now at 101.85% and 22m 30s remaining

How many % complete will it go??


Still going at 117% – it should be noted I still have not started any apps or initiated any file transfers. I did try opening a video file which worked okay.


Looks like the scrub finally completed and disk usage went to 0 – I might have even found the manual start button I was previously looking for :partying_face: