Fresh install won't start web browser

Hi, I’ve installed TrueNAS Scale but the website is not starting. When the system boots it shows a lot of dots, and after some minutes then the menu of “Select one option 1-9” appears (the dots still are being added):

I saw one post that says that most likely it’s a problem of some critical hardware failing, and as this is a 13 year old nas server I ran a memcheck to see if it’s a ram issue, but I got no errors…
Any hint of what could be?

Looking at the services, I saw that some were failing (and for what I see at the description, some of them seems critical…):

The server is a Dell poweredge r720.
CPU: x2 Intel Xeon E5-2670 V1
RAM: x8 8GB RAM sticks
Drives: x1 1TB SSD (install drive) + x4 2TB SSD (still unconfigured, but will be RAID 5)

I’m using TrueNAS Scale 23.10.2 (the latest stable version).

What, exactly, do you mean by:

? You aren’t expecting a web browser to come up on the server console, are you?

Your browser won’t find a webserver on the URL given because (from the service status screenshot) it appears that:

  • You don’t have a working network
  • You don’t have a working nginx instance - but this may simply have failed because there is no working network instance to bind to.

You haven’t given details of what you have defined for console option 1. (network interface) or option 2. (network settings) so I can’t diagnose further.

@dan - that was my first thought too, but when I looked at the details I decided that if I assumed that they were using a web browser then it still wouldn’t work. :smiley:

… I’m not that stupid…

Entering the reported IP will prompt no server available. Running nmap shows both ports 80 and 443 as “not listening” (most likely because the service is down).
What should I run to get more logs to help locate what the problem is?

@Protopia what do you mean by “working network”? May be a network card issue then?
TrueNAS reports an IP, and I can ping it from my other computer… Also, nmap shows some ports as “open” (tcp 111 and tcp 6000), but no website.

Also, again, it’s a “fresh install”. So no options defined on 1 nor 2; it’s all by default.

What version of Scale?

It appears to be mighty broken.

1TB SSD is a waste for a scale boot drive :-/

@Stux latest stable one.

I know 1tb is a waste, but it’s the only spare drive I have (and I’ve read that USB drives are bad)…

1 Like

I see that ix-etc.service (the one that “generates the /etc files”) fails because a timeout. Then the next one to fail is “ix-netif.service” (that should setup all the network things) and just reports as “returned with exit code”

Exactly - ix-netif failed, so your network interface is down, and nginx also failed probably because it couldn’t bind to a network.

It seems likely but not certain that ix-netif failed because ix-etc failed, but that is not certain.

Why ix-etc failed is where to start. Look in the log / journal.

How do I do that? journalctl tells me nothing as I’ve said

At the end I just had to let it run for a while… After 2 hours or so the dots/“+” stops appearing (and after that they don’t appear again after a reboot), and I can enter the website.

Truly weird.