FTP cannot ONLY connect to public ip


I have completed the setup of the FTP on TrueNas Scale.

If I try to connect from my PC to the TrueNas FTP using the local IP “,” then it connects normally and everything works.

If I try to connect with my public IP xxx.xxx.xxx.xxx:4444 with the same settings in the FTP client, then I get this message.

The port on my MIKROTIK router is functioning correctly, it’s open.

Where do you think there might be a problem?

Thanks in advance,

I’d guess its because you are using FTP passive mode and when you connect externally the port it picks is still blocked. Some good info on Active vs Passive mode here:

1 Like


Thanks for your replay,

I read the article you sent me, but apparently I’m missing something.

I have made these settings on TrueNas:

I have opened port forwarding on the router from port 55000 to port 21 for TCP.

Is my problem in TrueNas or in the router?

Since you can connect via the TrueNAS local IP just fine it would indicate that the issue is on router / firewall externally. You may want to review your router logs and details to see where packets are getting blocked.

FYI - Opening that wide range of ports is rather scary, don’t forward everything to TrueNAS like that :slight_smile:

I have not ever used RouterOS as a firewall. However, I’ve used many different corporate, prosumer and consumer firewalls. In most non-consumer routers, just allowing ports through the firewall isn’t the same thing as a “port forward”, and is infact, only half of the equation. Your issue may be how you have your NAT rules setup. In this case, it sounds like a DNAT problem. Please see: NAT - RouterOS - MikroTik Documentation