Fully reset Plex/Apps

I’m trying to reinstall Plex because it was giving me some transcoding errors that seemed like the simplest fix. I deleted the app, but when I reinstall it already has me signed in and wont let me configure as a library/fresh install.

How can I just get rid of all residual data from past installs of apps? I have tried deleting and reinstalling Plex a few times now.
TrueNAS-SCALE-24.04.1.1
PowerEdge R410

you may need to delete the associated PVC that store app data. This will remove residual configurations.

Uninstall plex, then access the shell and look for /mnt/pool_name/ix-applications/releases or just /mnt/pool_name/ix-applications/
inside, there should be a /path/to/plex/data.

rm -rf /path/to/plex/data

then re-install, that should get rid of all login data ect.

Thank you so much for your reply.

I tried that but don’t have permissions to delete that when I tried in the cli. I deleted them from the GUI, but they show up with zfs list

Permission issues can be a real pain. Here’s a step by step approach to see if we can resolve the issue.

  1. Verify the ownership and permissions of the directories you are trying to delete
    ls -l /mnt/pool_name/ix-applications/releases

  2. If the directories are owned by another user, you can change the ownership to your current user or root.
    sudo chown -R your_username:your_group /mnt/pool_name/ix-applications/releases

  3. Modify the permissions to ensure you have the necessary rights to delete the directory.
    sudo chmod -R 755 /mnt/pool_name/ix-applications/releases

  4. After changing the permissions and ownership, try deleting the directory again.
    sudo rm -rf /mnt/pool_name/ix-applications/releases/plex

  5. If the above steps still don’t allow you to delete the directories, you may need to destroy the ZFS dataset associated with Plex.
    sudo zfs list

Then, destroy the dataset:

sudo zfs destroy pool_name/ix-applications/releases/plex

  1. After deleting the residual data, you can reinstalling Plex. This should allow you to set it up a fresh installation.

If you still have issues, try running the commands as the root user or using sudo
If you are still unable to delete the files or datasets, please provide any error messages you receive.
Hope that helps

Thank you so much. I did that and was still having issues so I tried a fresh install but accessing it with private mode so cookies couldn’t affect anything. Turns out that was my issue.
My browser was forcing plex to assume I had signed in before, and there was no set up to do. I logged in with a different account, configured, and I was good to go!