Getting error in Veeam when I try to access my SMB folder on TreuNAS

I have managed to make my SMB on TrueNAS visible even from Windows, I can map that SMB on TrueNAS from my PC with windows 11, now when I try to create a new repository in Veeam Backup that points to this SMB I get this error that is seen In the image, I also incorporate an image of the SMB in TrueNAS. Has anyone gone through the same problem?

Looking at your images it does not look like credentials have been provided to Veeam.

Try checking the credentials box and providing Veeam with SMB credentials with proper permissions.

Ok, I tried this and I get this other error. I also publish how the access to the SMB resource is, I even allow my PC access through the IP.

Typically I would suggest using a specific user for Veeam backups, not the admin user.

Is Samba authentication enabled for Admin? Credentials → admin → Edit → bottom of the edit user screen.

Sorry it wasn’t enabled but when I try to do it I get this error.

Suggest creating a new user, veeam for example, configuring proper permissions, and using that user/credentials to access the share from Veeam.

1 Like

I did it, look at this. This is the new user, with SAMBA authentication but i get the error again in Veeam

Screenshot 2024-04-30 163932

Does the Veeam user have permissions for the veeam dataset?

I actually assigned permissions to the veeam user on that folder, as you can see in the screenshot

Missed this earlier, but your SMB share is most likely incorrect. You have the full path of the dataset, your SMB share is likely just “\\\VEEAM-BACKUPS”.

You can verify your SMB share names by going to the Sharing screen.

I had done that, and I get this error. I verified that the veeam user is created in TrueNAS and that it also has permissions on that share and activated the SAMBA compatibility box.

Hello friends
I solved the problem. The machine where Veeam is installed had to be declared as a Gateway server. The veeam user was not necessary, or at least I did not need it to install the repository that I have in TrueNAS because although I still do not understand it well, I think I have understood from what I read in the Veeam help that either giving the host name of the TrueNAS or The IP was enough, anyway, when I declared my PC as a gateway server in Veeam, the connection with my repository in TruNAS was satisfactory. I’ll let you know if the backup I’m planning to do tonight works. Thanks a lot to everybody who help me. I thought it reasonable to share the solution I found.