Gitea app stuck in Deploying state

Tried deploying gitea app but it is stuck in Deploying state for 12h.

# kubectl get pods -n ix-gitea
NAME                              READY   STATUS             RESTARTS       AGE
gitea-77d59479cc-tp46m            0/1     Init:1/2           0              12h
gitea-postgres-7c5685d8dd-rl5cr   0/1     CrashLoopBackOff   23 (78s ago)   12h

# kubectl logs gitea-postgres-7c5685d8dd-rl5cr -n ix-gitea

initdb: error: directory "/var/lib/postgresql/data" exists but is not empty
initdb: detail: It contains a dot-prefixed/invisible file, perhaps due to it being a mount point.
initdb: hint: Using a mount point directly as the data directory is not recommended.
Create a subdirectory under the mount point.

Is this the official TrueNAS Gitea App? If so you may want to file an issue so we can address it:

Him also having an issue getting Gitea to install. However Im running TruenasCore 13 u6.1. Im running the install from the community plugin section. I’m attempting to install it as I have done with my other applications. Though I also had the same issues trying to install Gitlab and had the same failure. Maybe I have something more going wrong?

I went back to CORE and run Gitea in a virtual machine.

Hello Kindart,

Interesting thank you. By chance was your issue similar to mine? How much resources did you assign to the VM for it? Its suppose to be light weight.


Plugins are a dead feature walking and should really never be used. If you can manually install the software in a jail or there’s a script for it, fine; otherwise you may want to use a VM.

1 Like

1GB RAM/1 CPU/10GB disk is enough for a light use.

Hello Dan,

Oh really. Is the plan going forward with Truenas that plugins are not going to be supported? Does that also include the Truenas supported plugins? The two main I use are the Plex and Unifi Ubiquiti tools.

For my BlueIrus setup I did do a win10 install on a VM which has worked pretty well.

Dan thank you for your message.

Hello Kindart,

Thank you. Ill use something like that as a VM in the future for small features to add.


Yes, that is very much the plan going forward. See:


1 Like