Help please - I have managed to ulmost Brick my TrueNAS

Please can you help?

I have managed to get my TrueNAS Scale sytem into no longer work properly. It functions as a NAS over my Network at my home address via SMB. But I cannot get it to do anything else?

I have endeavoured to resolve this using help guides and Tutorials on YouTube, but I have managed to almost Brick it.

It now says that none of the Apps are working, nor can I connect from outside my Network at home.

I am unsure what I have done, as I have just gone around in circles making the situation worse.

I cannot even submit a Ticket via Jira;

error FAILED - Cannot connect to host ssl:default [Temporary failure in name resolution]

Please can anyone advise as to what I can do? I have tried Updates, but these don’t appear to be inatalling? Or do I have to start over and reimage my PC?

Any help would be greatfully appreciated.

May I suggest you start by telling us what version of TrueNAS you installed on what hardware, what services you have enabled, and what specific things are broken?

OS Version:TrueNAS-SCALE-24.04.0

Product:Wyse 5070 Thin Client

Model:Intel(R) Pentium(R) Silver J5005 CPU @ 1.50GHz

Memory:8 GiB

Your network configuration looks to be completely broken. Please send a full screenshot of your network tab.

1 Like

Also seems like a very marginal system to be running large kubernetes clusters and TrueNAS on. Not enough RAM.

1 Like

I went down a rabbit hole trying to get Wire Guard added and setup.
I had issues… and couldn’t find my way back?

I have a BT Smart Hub 2, and I have read that this might be the root cause?
But either way, I cannot seem to be able to modify or change any Network Settings?

So probably a wipe and reinstall is my only option?

You don’t have any nameservers (DNS) set. That covers two of those alerts at least.
Network → Global Configuration → Settings → Nameservers

The other two in relation to k3s I haven’t seen before. You could try changing the Node IP in Apps → Settings → Advanced Settings (either to or and hope middleware does some magic to fix whatever the lookup error is.

I’ve just tried that, but it didn’t work?

I also tried changing back from the br0 to enp1s0, but it won’t let me?

So I have really thrown a spanner in this one!
I was just hoping someone might have the magic idea to save me starting from new.

Thanks again :slight_smile:


Default behavior here is for the Route v4 Interface to be unset (shows up as -- in the menu selection).
Here’s a screenshot of mine for reference:

Did you add a nameserver as essinghigh mentioned? Nothing is going to work without one listed so this should be your priority. You should be able to use the same adress as your router, which appears to be (but verify that if you can).

Also, for completeness sake, please click the pen-icon next to the br0 interface on the Network screen and post a screenshot of that info, just so we can see the full bridge setup.