How do I troubleshoot no automatic Time Machine snapshots

I am new to TrueNAS SCALE. Installed I have one dataset for storing Time Machine sparse bundles. Two machines have been backing up multiple times per day, but the only snapshots I see are ones I created. The dataset is only used for Time Machine and contains a sparse bundle directory for each machine.

I am not sure what I can do to troubleshoot this problem.

Have you enabled periodic snapshots under the data protection menu?

I had not set up any periodic snapshots yet. I did look at the screens for doing that when I noticed no automatic snapshots getting created. There was nothing on them that mentioned automated Time Machine snapshots and it did not seem likely to me that I had to set up a time based snapshot when that might be run while Time Machine was using the share.

I set one up, ran a Time Machine backup and still do not see an automatic snapshot for the Time Machine run.

It should work automatically if you set up a Multi-User Time machine.

Is it not? Did you setup a multi-user time machine?

I’m guessing the issue is that your time machine dataset is not actually setup as a multi-user time machine dataset.

I actually make a dedicated user for each user’s machine that is getting backed up. This way I know the password, and not necessarily the user, as I find I’m the one setting up time machine backups for family etc…

Ie, on the user’s machine, when logging in to the time-machine share/dataset in the time machine settings, you login as the machine user… rather than the machine’s user… if that makes sense :slight_smile:

1 Like

The dataset I am using for Time Machine was imported from an Open Media Vault server and contains more than a year of history. The only way I could get the Macs to connect was using the Basic Time Machine share purpose. With the multiple user share, I end up with the extra directory at the top for the user. I did not try to move the sparse bundles into that directory.

Maybe having the share set up for multiple users and having each Mac using its own username is a requirement for the automatic snapshots to work. Maybe there is something “bad” about having two or more sparse bundle directories in that dataset. Maybe there is something wrong with the permissions.

Shotgunning configuration changes into this thing in an attempt to make it work does not feel like a good solution. Is there some logging information that might point out whet the problems are?

@Stux: I decided to give up using the existing sparse bundles and attempted to do what I think you were recommending for one of the Macs to see what happens.

  • Created a mba-2022-01 administrator account on the Mac with a unique password.

  • Created a mba-2022-01 user on TrueNAS with a different password

  • Created new dataset called TimeMachine

  • Created new share called TimeMachine with the Purpose set to “Multi-user Time Machine” and did not change the ACLs

  • Logged into the Mac with the new user.

  • Deleted the existing Time Machine disk reference.

  • Added new TimeMachine disk, using the mba-2022-01 user that was created on TrueNAS.

  • Started a new Time Machine backup

The backup starts running and two new datasets appear under the TimeMachine dataset. One is named mba-2022-01 and another is named dave. The backup creates the sparse bundle directory in the dave dataset and leaves the mba-2022-01 dataset empty. Those datasets have owners and groups that correspond to their respective names. The sparsebundle directory is owned by the user dave. Looking at the SMB status screen in TrueNAS, it shows one session running under the user dave.

The dave account on the mac is the first account that was set up on the machine when new. It was also the account used to do Time Machine backups to OpenMediaVault. I made sure I logged out of that account before starting this process. I have no idea how time machine decided to write the sparse bundle using that username.

With all that said, an automatic snapshot did show up after the first time machine backup.

I will have to do more testing to see what happens if configure the other mac to use the new TimeMachine dataset and another machine specific user. I am guessing I’ll wind up with two sparsebundles under the dave dataset and nothing under the datasets named after the machines. At least I have a long weekend to play with it.

I’ve never tried making a new user account on the Mac, rather make the account on the TrueNAS, and then login in the Time Machine control panel, not in the finder


I was unable to figure out why my Mac kept using the dave account instead of the machine specific account, mba-2022-01, when connecting to perform a backup. I removed the backup drive from Time Machine and added it back using the mba-2022-01 account credential but the Mac kept using the dave account to do the backup. I tried using “tmutil setdestination” with the same results. It also did not matter if I used an account other than dave on the Mac when adding the backup disk, so I deleted the mba-2022-01 admin account I created earlier on the Mac.

Here is what finally worked.

  • Created TimeMachine dataset.
  • Created a TimeMachine share with the purpose set to Multi-user Time Machine
  • Changed the password for the dave account on TrueNAS to something the Mac had not used to connect to TrueNAS shares so the Mac could not automatically connect to shares using the dave account.
  • Deleted the Time Machine drive and added it back using the mba-2022-01 TrueNAS account/password.
  • Ran a Time Machine backup. It was successful. TrueNAS created an mba-2022-01 dataset inside the TimeMachine dataset where it wrote a mba-2022-01.sparsebundle directory. TrueNAS also created an automatic snapshot on the mba-2022-01 dataset the the backup completed.
  • I left it run for a day to make sure it kept working. Then I repeated the Time Machine setup steps on the other Mac. It also worked.

@Stux : Thanks for the suggestion to use separate accounts for each of the Macs.


Awesome :slight_smile:

I think, you may have been able to get Time Machine to forget the Dave account by deleting the credentials in keychain.

I seem to remember that now that you’ve figured it out :slight_smile:

1 Like