I can't see my drives in TrueNAS Scale

Alright fair enough. I guess I’m just so confused why I can’t see any drives in TrueNAS or otherwise. Maybe because I have too many? I do remember when I first got the server and I only had 4 drives in the front bays I tried installed TrueNAS and I remember seeing them.

But then I wanted to try PROXMOX. And haven’t seen the drives since. I’ve since removed PROXMOX and gone with just bare metal storage. So maybe I try clearing cmos and starting it all over from scratch. Or at the very least start with taking out drives.

I also did have to edit the BIOS (Edited BIOS) and flashed it via the IPMI interface so that I could boot from an NVMe drive that I have installed on a Supermicro AOC-SLG3-2M2.

Is there a chance that messed with the ability to use the HBA controller?

1 Like

No, that’s not a thing.

What on Earth? You’re sure that Supermicro’s latest firmware doesn’t include an NVMe driver? That’s insane, even ASRock got their Xeon E5 v3/v4 boards updated with a driver. In any case, it shouldn’t be a problem.

Focus on the HBA. Does the OS see it? Do LSI’s applications talk to it? Etc…


I think someone already asked about this. Oh yes:

1 Like

The specs listed on the purchase site and on the Supermicro site the purchase site (I found it’s a good company to buy from) linked to indicate it has a Active not passive backplane. At least one of the cables in the photo taken by the OP is a Supermicro CBL-SAST-0593 which enables internal MiniSAS HD to MiniSAS HD connections for storage and the backplane. The photo also shows a heatsink so it is an active SAS backplane and not passive backplane. The two cables also appear to be connected to two connectors on the backplane which are inline with the backplane manual I linked to. You cannot as far as I know and by some testing I did on a different system install SAS drives to a SATA backplane that is connected to SATA ports on the motherboard, it just will not work at all. SATA does not support SAS but SAS will support SATA.

The best bet if you want to use this backplane and the 12 hot swap slots on this chassis then you need to connect it to the appropriate SAS card according to the backplane manuals instructions. and be done with it.

I believe the chassis supports internal drive mount configurations. If that turns out to be true then additional drives can be mounted internally and connected to the motherboard SATA ports.

There are also 2 Active SAS backplanes for the chassis listed. One supports 4 NVME drives if they are in certain hot swap bays and the other does not support NVME.

1 Like

This is a relevant point. -N4 backplanes have four extra SFF-8643 connectors for PCIe only. Connecting a SAS HBA to them would be pointless.

this is what was returned after I input the command.

So it seems it is not seeing the HBA. I’ve even tried putting the HBA into a different PCI slot. Still won’t work.

And confirmed it is a EL1 backplane.

I don’t know if this will be helpful at all. But here are some screen grabs of the boot up process when I start TrueNAS.

Agreed. Not a good sign.

And a SAS3 one at that. Pretty decent upgrade compared to what the specs said. That means you can forget everything we said about connecting to the motherboard with reverse breakout cables and the like; @PhilD13 is correct that you’d only be able to connect the backplane to a (functioning) SAS controller.

I don’t see much helpful in your boot output, other than that it looks like the system sees your backplane. Interesting. That would make it sound like something’s working with the controller. What’s the output of lspci | grep SAS?

I suspect the backplane, during the boot process shown, is connected to the motherboard SATA ports and thus PCH GPIO, since it’s lumped in with SATA/AHCI devices and explicitly lists AHCI. That’s one of those things that’s sort of supposed to just work, at least if you have Supermicro on both ends, but that I’ve never seen documented.

1 Like

It comes back with nothing. I try to input that and nothing comes back just starts a new line in the shell.

Well what would the next step be? I seem to be getting power to the backplane it powers on and lights blink, and I can hear the drives spinning. I did try checking every connection on the backplane going to the mobo, to the controller, to power. I even tried different power connections on the mobo to the other PSU. It does seem to being working, just not recognizing it. Should I try a new HBA and cables as a first step?

I know this is a lot and y’all have already contributed a lot of your time to this, and I am eternally grateful. But would either of you be down to join a discord call and maybe I can share my screen and we can go through some things? If not, no worries I still appreciate all the help y’all have given me and thank you.

That’s sounding very much like a dead HBA. If you have another computer you can put it in, it’d be interesting to see if it’s recognized there, but your system doesn’t seem to be seeing it at all. And if that’s what was connected to your backplane, as you stated, that would explain why your drives weren’t seen.

Ok I’ll start with a new HBA and cables. Would these work?
LSI 9300-8i
SFF-8643 to SFF-8643 cable

And because of what was mentioned before I don’t need a LSI 9300-16i to be able to access all 12 bays. Because of the specific backplane I have a LSI 9300-8i with at least 1 cable should be able to do all 12 bays on the backplane. Am I understanding that correctly?

The backplane should not have any connections to the motherboard, not directly anyway, only to the HBA. Plug the cables into the HBA instead of the motherboard and see if it starts showing up (LSI SAS controllers sometimes don’t boot if they don’t have anything attached).

That’s correct. And the 9300-8i would be a very good choice. You will want to flash the firmware to the correct version, though; see:

Edit: I haven’t seen any indication that your cables are a problem. You might want new ones just to be on the safe side, I guess, but nothing now suggests there’s anything wrong with them.

I meant like the cables for power and the like. No data cables are going to the mobo from the backplane. The only two cables that come off the backplane are two SFF-8643 cables going directly to the HBA. I have not attempted to connect the backplane to the mobo using a SFF-8643 to SFF-8087 cable or any other breakout or anything else. This entire time I have only connected the backplane to the HBA.

Ok wonderful, I will look into all of this then. I’ll just order two new cables its only $25 just to be on the safe side. But I’ll try the existing ones first.

ITS WORKING!! ITS WORKING! Now this is podracing!

Now I have to figure out why its only showing 5 of the 6 12TB drives. But I can finally see my drives!!!

I’ll update the HBA to the right firmware version and check all my connections. But at least I’m getting somewhere now! Thank you thank you thank you thank you guys so so so much for your help, I honestly could not have done this with out y’all.

Solution: get a new HBA controller lol