I can't see my drives in TrueNAS Scale


So I just installed TrueNAS Scale for the first time on to a Supermicro server I just purchased (Supermicro 12x bay 2u server). And I looked I do have a controller (LSI SAS 9311-8). Which I am now finding out only has capabilities of doing 8 drives. And I currently have 10 drives plugged in.
6 - Seagate Exos X18 ST14000NM000J 14 TB Hard Drive SATA
4 - Seagate Exos X18 ST16000NM004JSP 16 TB Hard Drive SAS

But I still am not seeing any drives when I try to create a pool. The only one I see is my other optane drive that I have installed on my add-on card.

Is it because the controller is flashed to IT mode? Or am I just missing something. I am just not sure why I can’t see any of the drives I have installed. And will I need another controller or a different one in order to be able to see all the drives. And eventually I would like to populate the last 2 bays and have 12 total drives. So what Can I do then? Any help would be greatly appreciated, thank you!

I’m not familiar with a 9311-8–I know the 9211-8i or the 9300-8i, but not a 9311-8anything. But regardless, either of those cards would support far more than 8 drives with a SAS expander, but sadly you’ve chosen a server without one of those.

The server you have has a Supermicro -A backplane, which means it needs one SAS connector per four drive bays. Since your motherboard has 10 SATA ports and your SAS controller has (effectively) eight, you can feed the backplane with either (1) two SAS cables from the HBA and one reverse breakout cable to four of the SATA ports on your motherboard; or (2) two reverse breakout cables to eight of the SATA ports on your motherboard, and one SAS cable from the HBA to the backplane. Regardless of which you use, the SAS drives need to be in drive bays that are connected to the SAS HBA.

How do you currently have the backplane connected?

You may also find this helpful:


It looks as if it’s connect via these two cables from the backplane to the HBA controller mentioned in my original post.

And it looks like I only have 2 SATA 6gb ports and two of these other connectors, that I’m not sure what kind of SATA connector they are.

Would it just be easier to get a new controller that can handle all 12 bays without having to do reverse breakouts? I also tried to plug the cabes into the top previously unpopulated ports on the backplane and I still can’t see any drives in truenas.

They aren’t; they’re SAS connectors, which will simplify connecting the motherboard to the backplane–just use a SAS cable for that as well.

So right now, if all you have connected to the backplane is the HBA, you only have eight bays available. That could be part of the problem–drives in wrong bays–but it wouldn’t be all of it. Do you have power connected to the backplane? Do you see the disks listed in the BIOS, or any other reference to them when you boot the machine?

If you see drives in the BIOS or otherwise in the boot process, try going to the shell and running lsblk. What do you see there?

I do have power connected to the backplane. I have blue lights on currently.

Here are screenshots from my BIOS

The eSATA page looks the same.

The HBA is currently plugged into a RSC-R1UW-E8R riser card. I don’t need to bifurcate it do I?

The SATA configuration pages aren’t especially helpful. But where you’re given boot options, I’d expect to see at least some of the drives you have installed listed as options.

On my system, after the normal POST completes, my HBA lists all the attached drives before I get the Grub menu to boot TrueNAS. Do you see any output from the HBA as part of the POST process?

No, no need to bifurcate.

Kind reminder that imgur and other external image hosts are not welcome. Please upload images directly to the forum. Thanks.


No I don’t see anything like that before the Grub menu. And lsblk comes back as this:

I’d love to, but I can’t upload more than 1 image because I’m new. And I am trying to show more screenshots. Unless there is another way to have multiple images in one post.

That’s an odd limitation, I’ll raise it for discussion. Thanks for pointing it out.


OK, between that and what you aren’t seeing on boot, doesn’t look like your drives are being seen at all. Still at the shell, what’s the output of sudo /usr/local/sbin/sas3flash -listall?

We’ve bumped up the limit to five for now. That should cover 99% of cases. We’ll keep an eye on this sort of thing and keep iterating as necessary.

In any case, please reach out to the mod team if the forum is making your life difficult needlessly.


I’ll check when I get home from work this evening and post the screenshot. In the mean time I ordered this SFF-8643 to SFF-8087 cable to at least get some of my drives to show up. It comes tomorrow.

Thank you! That is helpful, I appreciate your willingness to make this process easier.

When looking at the documentation based on the link you provided, it might help that the Backplane looks to be a SAS backplane and needs to be connected to a SAS card and not internal SATA ports on motherboard which are SATA only. The spec page on Supermicro for the chassis gives the cards compatible with the system. SAS backplanes will accept both SAS and SATA drives and needs to be connected to a SAS capable card, but a SATA connection only accepts SATA drives. I’m not clear on the Supermicro documentation where they connected the backplane or if they connected the backplane when using SATA drives.

The documentation does reference when using a SAS card then 12 slots are available for either SATA or SAS and this statement is an important bit of information (in bold below) on this chassis. and would match the hot swap bays. Otherwise the documentation vaguely references internal drive mounts but no connections references.

SATA 10x SATA3 (6Gbps) ports
SAS 12x SAS3 ports support via optional Add-on Card

The manual referenced on the specs page for the backplane is here (note: backplane model is printed on the backplane in case this is wrong)

Backplane manual list the three connectors on the backplane as being SAS.
7. SAS IN #1: JSM1
8. SAS IN #2: JSM2
9. SAS IN #3: JSM3

This means the backplane needs to be connected to a SAS capable card as referenced in the above chassis specs and will not work with the SATA ports (at least I could never get a SAS backplane to connect to SATA ports). Once connected properly to the proper card, all the drives should show up.

The actual specs on the server is here

you can download the manuals from that page.

The Riser card in the chassis should be fine if it is a Supermicro riser. Also you must have both cpu’s installed for all the pcie slots and both riser card slots to work. Otherwise only half the slots will work and they are not necessarily in order.

1 Like

It’s a passive backplane, as denoted by the “A” designation, as opposed to “EL1” for single-expander, “EL2” for dual-expander and “TQ” for trainwreck. It’s fundamentally no different from a bunch of cables. It will work just fine with SATA host controllers.

1 Like

So I definitely have both CPUs installed.

But in reading the manual it states when enabling the SATA and sSATA options in the bios drives are controlled by the PCH chip. So I wonder if I disable SATA and sSATA in a he bios my HBA controller will take over.

And maybe it is best to use a controller that will be able to handle all 12 bays instead of doing 8 on the controller and the other 4 on the mobo.

But, as mentioned you need “reverse break out” cables, which are the opposite of the normal mini-sas to sata breakout cable.

Does that mean that an mini-sas-hd to mini-sas cable is different to a mini-sas to mini-sas-hd canle?

I’ve run a similar situation, 16 hba ports and 8 from the main sata/ssata since 2017 and it’s worked just fine :wink:

I wouldn’t bother installing extra sas ports.

No, of course not, look at the block diagram. The on-board SATA ports are just that, SATA ports, they have nothing at all to do with any SAS HBAs you might install. Not that such a concept is impossible, but I’ve never seen it done (it’s far cheaper to just add a few connectors than to try and multiplex all those differential pairs). If you disable those ports, you disable those ports. That’s it.

I just noticed you have a heatsink on that backplane. That means it’s an EL1 or EL2, which means that SATA hosts will not work. It also means that you don’t need 12 host ports, just a single cable (or two) will do and the backplane’s expander will do the rest.

So: Focus on figuring out the state of the SAS controller, forget the on-board SATA ports.


Interesting because on the listing from the server store. It specifically lists the backplane as a: BPN-SAS3-826A. When I get home I’ll take a closer look at it and try to find a serial or part number.

Is the HBA DOA?

That would explain it.

Do you see any evidence at startup that the HBA is installed?

In the old SAS2 adapters you could remove the bios oprom when flashing and thus see nothing during boot up.

BUT, if it’s an active backplane, and if it’s already wired up, and you’re seeing nothing, then maybe the cards not installed corectly, faulty, or maybe the backplane is not powered up.

Maybe you need to ask your reseller?